Getting BL touch to work on a 4.2.2 board with Ender 5 Pro

So i have a 4.2.2 main board with a Gd chipset. I learned there where two different firmware updates due to this. Have installed the one for what i have and have hooked up the BL touch to the 3 proper pins as well as the Z stop plug. I get the unit to do all the right probe testing moves. I also got it to hook up via the USB cable and got it to list all the settings on screen. I tuned off the safety setting which keeps it from running in the minus off direction. But each time i try to move the z offset i can not get it to run in a negative direction ( lifting the build plate upward). No idea why but makes it impossible to set it up…
Hope someone can help? This is the listing and errors i get from the
printer program

SENDING:M503

echo: G21 ; Units in mm (mm)

echo: M149 C ; Units in Celsius

echo:; Filament settings: Disabled

echo: M200 S0 D1.75

echo:; Steps per unit:

echo: M92 X80.00 Y80.00 Z800.00 E92.60

echo:; Maximum feedrates (units/s):

echo: M203 X500.00 Y500.00 Z5.00 E25.00

echo:; Maximum Acceleration (units/s2):

echo: M201 X500.00 Y500.00 Z100.00 E1000.00

echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>

echo: M204 P500.00 R1000.00 T1000.00

echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
echo: M205 B20000.00 S0.00 T0.00 X6.00 Y6.00 Z0.40 E5.00

echo:; Home offset:

echo: M206 X0.00 Y0.00 Z0.00

echo:; Auto Bed Leveling:

echo: M420 S0 Z0.00

echo:; Material heatup parameters:

echo: M145 S0 H200 B60 F255

echo: M145 S1 H240 B70 F255

echo:; PID settings:

echo: M301 P17.97 I1.46 D55.15

echo: M304 P96.72 I16.17 D385.83

echo:; Power-Loss Recovery:

echo: M413 S1

echo:; Z-Probe Offset (mm):
echo: M145 S1 H240 B70 F255

echo:; PID settings:

echo: M301 P17.97 I1.46 D55.15

echo: M304 P96.72 I16.17 D385.83

echo:; Power-Loss Recovery:

echo: M413 S1

echo:; Z-Probe Offset (mm):

echo: M851 X30.50 Y11.50 Z-2.50

echo:; Filament load/unload lengths:

echo: M603 L0.00 U100.00

echo:; 0:en 1:cn language change font:

echo: M414 S0

IF I HIT THE DOWN FOR THE Z STOP I GET

Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)