CR-6 SE - Replaced Switch, will not boot



  • @Admin, I have been having the power switch issue for quite some time, however I was finally able to secure a replacement switch. The switch has been installed, and all appears to be good on the hardware side (the machine powers on, I am seeing proper voltage from the PSU and 24 volts to the main board. I powered on the unit the first time and it seemed to boot fine all the way to ready to print. I then powered down the printer, dropped the latest firmware onto an SD card and booted again with the card in - I was met with a Creality loading screen (Creality logo, empty progress bar) that was just frozen, no progress. (I waited at least an hour). I removed the SD card to try and boot normally and I am met with the same screen. There was a full day between my last power down and the power-up for firmware udpate, so I cannot confirm that it booted fine the next day (I should have booted it straight first), so either the firmware update attempt did something, or the machine simply isn't booting after the power switch change.

    In my power diagnosis all looks fine, blue light on the motherboard. I did notice that the second set of test terminals on the motherboard (there are 4 in the green block) register 0, but the first two register 24 volts. Should that second set of terminals be carrying power? Or any suggestions on how to proceed to un-brick this unit? 😞



  • @EventHorizon glad that worked out for you fingers crossed you get some prints out now 20 days would have killed me I have Christmas presents printing atm 5 rolls of filament and counting (trail by fire) my favourite way to get to know a machine.



  • Dear @EventHorizon

    Really sorry for the late reply, I have confirmed with the engineer, please do as follow:

    About the green terminals on the motherboard: the first group is the input dc24v; the second group is the output interface of the hotbed (dc24v output only when the hotbed is heated)

    1, Press the screen button to see if there is a feedback sound (feedback sound is basically bad screen) / unplug the screen cable; if the knob is pressed no buzzer feedback sound on the next exclusion test

    2... Only screen cables and power input are left on the motherboard, unplug all the other cables and then power on the board to test (if the board starts up normally, plug them in one by one to troubleshoot the parts).

    1. Reinsert the screen cable and the motherboard socket of the screen cable.


  • @EventHorizon said in CR-6 SE - Replaced Switch, will not boot:

    You were correct in that I had already tried the 4KB block size, no Chinese characters, etc. The only piece of the puzzle was that I did not have any 8GB SD's, the smallest I had in either straight SD or MicroSD in an adapter was 32GB

    How did you format a 32GB card with 4096 byte allocation size without repartitioning the card?



  • @gazman1985 Yeah it definitely has a boot order, and the SD comes first. When I started having the problem, though, I tried booting without any SD at all as well to no avail. You were correct in that I had already tried the 4KB block size, no Chinese characters, etc. The only piece of the puzzle was that I did not have any 8GB SD's, the smallest I had in either straight SD or MicroSD in an adapter was 32GB. Given that I had read elsewhere in the forums that larger shouldn't be an issue as long as the cluster size was correct, and that Creality just "suggest" an 8GB card, I didn't look back. So, today I decided to take one of those cards and partitioned it at 7.43GB/FAT32 (available space of an 8GB with 4KB cluster) just to be sure I was below any threshold. I then dropped the firmware binary on there, and FOOM, it WORKED. I was now stuck in Chinese, and the language setting in the menu non-functional... which made me realize that the screen firmware and the device firmware must have gotten to the point of needing to be both updated. Grabbed a MicroSD, disconnected and opened the screen to access the Micro SD slot, and followed the same process but with the DWIN_SET folder at the root.

    I now have it back in English with a working language menu, the printer is responding, and a test print is going as we speak. I did notice another menu option not working when I was testing the navigation, but It is something I had not used prior, so I don't know if it's just never worked, or if there is still an issue with my update. Regardless, I will investigate that further once the test print is done.



  • @EventHorizon apparently after just reading a log file that can happen if the firmware file name contains Chinese characters so I think the suggestion above will work as they then go onto say if this happens make sure the firmware file contains no special characters and try again. Fingers crossed 🤞 this helps you out.



  • Hi @EventHorizon

    Not an admin just a another cr6 owner, I'm guessing you probably tried this but my thought is that the boot code is looking at the SD before the Eprom for firmware based on the update process, so something you could try maybe with another known good SD card is partion it to have 1 active partion thats 4gb at 4096kbs allocation size whack the last known good firmware which I think is 1.0.36 as they just released a new one but its untested by users yet. Make sure thats the only thing on there the bin file and try another boot with that SD card, if I'm correct that may work and hopefully save / override the bricked firmware otherwise you may need to look at a board or higher level of support. If you bought from a reseller I've heard they are doing alot better for support times.



  • @admin This is now over 20 days with no reply while I still have no working printer. Could you please have someone look at the issue and advise on next steps?



  • bump I suppose? 12 days and counting. 😞 Does a thread that is all me, myself, and the proverbial I count as a leading indicator for multiple personality disorder? Regardless, at least I will have someone to talk to while I wait?

    Yes... yes you will.



  • @EventHorizon @admin Going on 7 days and no reply - is there somewhere else I should be posting for assistance? My printer is down and this is very disruptive to say the least.



  • @Admin any ideas? To be clear when I turn on the power I am seeing a blue light on the main board, and the Creality starting screen with progress bar (empty). This appears to be a default on power screen as there are no other loading indications. Once up it appears to just be frozen and never actually starts loading. Is there a hard reset or other process I might be able to try? Could the replacement power switch have anything to do with it? (I would doubt it since the main board is powering up...) I was excited to get to use my new printer after I finally found a switch to replace the faulty one, so this is a bummer. 😞


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.