New Firmware update 14th November

  • Dear @robthefish

    We have added a service request platform on our website, you are welcomed to leave your message here. Our after-sales team will help you.

  • @admin said in New Firmware update 14th November:

    Hi All,
    why does creakily download firmware offline
    We have just updated the firmware of Ender-3, Ender-3 pro, Ender-3 v2, Ender-5 pro, Ender-5/5s; they are all 32bit and for BL touch firmware, this update is for separate the bl touch with adapter board or without adapter board. Please confirm if you need it.


  • I just received my V2 a couple days ago and tried installing the 4.2.7 without BLtouch and it would bootup on the screen, but none of the controls worked such as, home, move. Its as if the steppers locked up. I installed a much lower version and that cleared the problem. What is confusing is the listing of the updates, there is no real description of what they are for, there are updates that have TMC2225 in the file name and some without. I have no idea if I need this, searching the internet just creates more confusion.

  • New to all of this firmware up dates etc. I have and Ender 3 Pro and updated to the silent board 4.2.7 running Marlin 2. I want to add the BL touch so I have downloaded the the RAR file for the BL touch without the adaptor board. The .Bin file loaded ok and the printer starts up fine. When it is told to auto home it homes the X & Y axis but when it goes to home the Z axis it drives out to the middle of the print bed, deploys the probe a couple of times and then stops. Stop message on display. In the move axis menu it will not allow the Z axis to drive down, only up. If I try to get it to level the bed it requests homing the Z axis but this is not possible. What is wrong? I have checked all the connections and they appear ok, after all it goes through self check ok so it must be doing something? Need to get this working as I can no longer print unless I put the noisy board back in which I do not wand to do!

  • Dear @NNYTech

    Please contact our after-sales team, they will check and give you a solution. Thank you.

  • I am trying to install the BL Touch to my Ender 3 Pro 32 bit. I am using the adapter. I have followed the instructions that were included. But I am unable to get the new filmware to load from the SD card. The filmware files on Creality site are all RAR files. The EXT in the instructions is EXT BIN. Do I have to extract the files from RAR format first? What is a good program to do that with for a Windows system?

    Thanks for any help.

  • So I upgraded the firmware for my 4.2.2 with BL Touch Creality kit. I flashed the firmware and now you can't store settings in the EEPROM I get an error when I send a M500 to board eeprom not found. Maybe you should post the source code so we can compile and configure?

  • @yenals I'm having the same issue with setting as well sending an M500 command gives me an EEPROM error message.

  • I can't save any settings to EEPROM in addition to all the issues mentioned above.

    Home position randomly changed, no more beep, default settings every power cycle and settings only save to SD.
    That can't be right, can it? No EEPROM storage for settings and offsets?

    E5Pro, Marlin 2.07 BLT, 4.2.7

  • I have recently bought a Ender 5 pro and to my initial delight discovered it has a 4.2.2 board installed and I presume TMC2208 drivers. As like lots of others I get a TMC CONNECTION ERROR and although everything's works I assume that this must be connected to the firmware. In the printer info it says that the firmware version is 0.0.8 which I can find no reference to anywhere. Like most I would like to have the latest most up to date system but all I find are firmware versions that assume BLtouch is fitted. I have not got any auto bed level device and cannot,based on results I've had need any. Why, if there is more up to date firmware I cannot seem to find it or a version that is suitable for the machine as purchased?

  • Is any of the FWs ok for an ender3v2 with 4.2.2 board without a BL touch installed?

  • Here you have a lot of firmwares for Creality printers with all the functions activated.

  • Lets just put it simply, that the firmware by Creality is JUST their custom tweaked OLD marlin 2.0.1 (we are on at time of this post) So its fine to use Creality firmware, but if you want extra functions you will have to use a later version of marlin i.e 2.0.7.x

  • @renatojd said in New Firmware update 14th November:

    Same here. Also M300 is also been disabled so I can't get a tone for start and end print jobs. This is really sloppy work overall. Can we just get the Config.h and Config_adv.h files? I'll just recomile it myself.

    Would be much easier, as every user could activate/desactivate useful features.

    I decided to buy 4.2.7 mainboard in order to get silent moves and micro-USB connection. I finally ended up with no more M600 and M300, which were both useful to me...

    Regarding the links to the new firmware on creality web page, what does with/without adapter stands for? I have an Ender3 with 4.2.7 without BL Touch. Which one do I need?

  • Bonjour, j'ai une imprimante creality Ender 3 V2 sans Bltouch. Mais ma carte mère est en 4.2.7.
    Actuellement ce firmware n'est pas disponible sur le site.
    Pouvez vous m'aider ?

  • This is precisely what I cannot understand. I have changed my 8-bit 1.1.4 board to this 32-bit 4.2.7 in order to take better advantage of the 32-bit potential and it turns out that the firmware is much simpler than the one with the 1.1.4 board installed. I do not understand how you can have such a large community of owners completely abandoned. That's why we see so many people avoiding buying the 1.1.5, 4.2.2 and 4.2.7 and upgrading their printers with SKR boards that are cheaper on top of it. If Creality continues down this path, it's going to lose a ton of plate sales to upgrades.

  • Same here. Also M300 is also been disabled so I can't get a tone for start and end print jobs. This is really sloppy work overall. Can we just get the Config.h and Config_adv.h files? I'll just recomile it myself.

  • I have installed a 4.2.7 board in my ender pro with bltouch. I have installed the new and old firmware and I have noticed that the Pause function for filament change is not implemented.
    For example: M600 is not accepted. Skip it and continue with the next instruction.
    Another example: Single bed leveling (Without BLTOUCH).
    G28; Home all axis
    G04 P500;
    M117 I go to point 1;
    G1 Z5; Lift Z axis
    G1 X32 Y36; Move to Position 1
    G1 Z0
    G04 P300;

    M0 S10 Press to continue;

  • So say i have the 4.2.7 without bl touch for my ender 3 pro i need to download the one that says

    4.2.7 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.1.2without adapter board TMC2225.rar

    is that correct and is this marlin 2.0 bug fix and what revisions have been made in this new firmware

  • What about the firmware update for the CR 6 SE that everyone is asking for when will that be available please

Log in to reply