Can't centre print on bed through Octoprint



  • I am a complete noob in 3D printing so I’m putting that out there straight away.

    I’m using a Creality CR-6 SE with OctoPrint 1.4.2 and OctoPi 0.17.0 on a Raspberry PI 4B

    If I print one of the gcode files on the SD card that came with the printer then it works fine and is centred on the bed and everyones happy. However, if I start a print from Octoprint the extruder does its thing then moves right to the front left-hand side of the bed makes a very griding noise like its trying to push even farther then its limits and starts to print off the side of the bed.

    If I view to gcode file this is what I’m getting

    Capture2.PNG

    I have tried both Creality Slicer 4.2 had the same problem, I uninstalled it then installed Ultimaker Cura 4.8 same problem.
    I have been asking the same questions of the Octoprint forum and the people there same to think it’s the slicer which I guess makes sense but how do I fix this problem

    Heres another example of whats happening

    Capture3.PNG

    If I position the cube in the bottom left corner like in the pic above then this is where it shows up in the gcode viewer in Octoprint

    Capture4.PNG

    Any help or ideas as to what where I should start looking for a fix will be very welcome.

    Thanks in advance.



  • @shinmai

    Well foosel the legend herself find the problem, I had the wrong setting in octoprint printer profiles under print bed & build volume, origin was set there to centre not lower left!

    Thanks for your help dude, maybe one day I can return the favor



  • @shinmai said in Can't centre print on bed through Octoprint:

    Have you tried printing files sliced in Cura from the SD card directly to bypass OctoPrint and rule it out as the one causing the offset?

    Nope but that will be the next test, good idea!



  • It's possible of course, but if the printer homes in the correct positions and all that, it'd be a very weird printer issue to then print exactly as if the file was being sliced with origin at the center of the bed.
    The Gcode file should use absolute coordinates, so if the printer homes correctly but the part is on the wrong place on the bed, it means that the Gcode the printer is receiving is incorrect, so the only culprits would be the slicer or OctoPrint.

    Have you tried printing files sliced in Cura from the SD card directly to bypass OctoPrint and rule it out as the one causing the offset?



  • @shinmai

    Yeah I already played around with the centering option and was told to turn that off its wrong.

    No I haven't tried comparing gcode in the way you suggested but I have setup another copy of Ultimaker in windows on a virtual machine and it gives me the exact same problem.

    If kind of makes me think its the printer itself to be honest but I am only guessing there



  • Where abouts would I look for the Cura Origin setting?

    It's the "Origin at center" checkbox in the Printer tab in your screenshot. Your settings and Gcode seem correct (other than the double extruder reset and Z axis move at the end, I assume from removing the code for extruding the priming lines).
    Have you tried visualising the Gcode with another tool besides Cura and OctoPrint to see where they place things?

    I assume since you've been talking with OctoPrint people that your settings for Origin there are correct?



  • Where abouts would I look for the Cura Origin setting?

    Here ya go

    Capture5.PNG
    Capture6.PNG

    Start G-code

    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate
    
    G28 ;Home
    
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    

    End G-code

    G91 ;Relative positioning
    G1 E-2 F2700 ;Retract a bit
    G1 E-2 Z0.2 F2400 ;Retract and raise Z
    G1 X5 Y5 F3000 ;Wipe out
    G1 Z10 ;Raise Z more
    G90 ;Absolute positionning
    
    G1 X0 Y{machine_depth} ;Present print
    M106 S0 ;Turn-off fan
    M104 S0 ;Turn-off hotend
    M140 S0 ;Turn-off bed
    
    M84 X Y E ;Disable all steppers but Z
    
    


  • Sounds like your Cura's Origin at center setting is incorrect (or possibly the Start Gcode, but that'd have to be REALLY wrong). What are your machine settings in Cura?
    You can rule out octoprint as the issue by printing the same file directly from the SD card and through octoprint, but I agree it sounds like a slicer issue.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.