CR-6 SE New Firmware Update 24th Nov

  • Dear All,

    We have the latest firmware for CR-6 SE, following is the address to download:


    Nine languages (Chinese, English, Japanese, Korean, German, French, Russian, Spanish, Arabic) are added to upgrade and cover for many language users.
    · Upgrade Auto leveling parameter storage method from SD card to mainboard storage.
    · Upgrade and fix for G20 not working in print.
    · Optimize Z-axis compensation memory logic to reducing the printing errors and improving the printing stability to optimize the print molding effect.
    ·Optimize stops printing zero function, greatly increasing the zero accuracies.
    · New support for displaying the preheat temperature even if it is not set.
    · Compatible with Octoprint temperature report, the temperature is controlled easily.
    · Upgrade to add the supported pause function.
    · Optimize the display problem on pause icon that makes easier and more convenient on printing operation,
    · Optimize the readjustment PID function makes more even and stable heating performance.
    · Add a 30-second screen shutdown function to reduce the power and light pollutions.

    Note: due to the file system is an incompatible problem, SD card of 32GB and above are not allowed to use in the upgrade process.

  • I bought my CR-6 SE printer in the fall and had a need to do some out-of-the-box printing straightaway. While it worked for the small footprint objects I was printing, the Z-axis homing and offset was inconsistent so I had to be careful about rechecking between every print. After searching about this phenomenon I came across this forum thread and it seemed to address what was by all accounts a firmware upgrade need.

    After studying the thread thoroughly I finally got around to doing the firmware upgrade. I have to thank all those who came before me working out the kinks in the "documentation" and process; as they say, "standing on the shoulders of giants". I used the 8 GB SD card (reformatted to 32K to 4K allocation size) that came with the printer to perform the main board firmware update. I managed to scrounge a 4 GB microSD card (also reformatted to 4K) for the display firmware update. Both worked the first time through the upgrade process. As indicated in a number of places, I do wish Creality would be more consistent in labeling the firmware package version information.

    Now the Z-axis homing and offset are consistent, at least as many times as I rechecked it from various random offsets.

    I also had to perform a Z-axis bed leveling to take out the skew across the bed. I found a video that indicated loosening one of the Z-axis pulley screws at the top and tweaking the lead screw will adjust the gross Z-axis offset across the center of the plate. The adjustment was a little tedious but doable and I got it very close by eye. It's a little off along the front and back edges of the plate, but now I hope the auto-leveling will have an easier time compensating for fine adjustments.

    Thanks for al the information and experience provided in this thread.

  • Hello,

    @admin said in CR-6 SE New Firmware Update 24th Nov:

    · Optimize Z-axis compensation memory logic

    this may be the reason for the raising "homing failed" issues. My printer is not able to find home anymore because between the two times the head is lowered in the center of the bed, it is moved up a little. First time the nozzle touches the bed, second time it stays in the air and the printer displays the 202 error message.
    So I guess the Z-axis compensation memory logic might intervene with the home coordinates.

  • @admin
    After firmware upgraded, I try leveling function. the heatend is crashing to the heatbed. The heatend and bed are not heating up.

  • YOU HAVE NOT FIXED SPIRIALIZE OUTER CONTOUR (Vase Mode). Getting the feeling I should have bought an Anycubic.

  • @shinmai Yeah it is really strange attitude, they have made it. They printers are popular. All they need to do now, is keep they customers happy and listen to they needs. Now we offer them to help, to find wrinkles in current firmware, and there no response.

    The result of this will be as soon another player comes in with more customer friendly attitude, and everyone will jump boat.

    I'm not going to lie I'm super happy with my CR6 so far (fingers crossed), i havent had any of the issues that other customers had, and prints quality perfect. And compare to my previoues printer this is joy ride. But looking how they dealing with their customers issues, makes you scared that if anything goes wrong you own your own.

  • @admin Release the source code ffs. Do we really have to go through the whole "GPL violating firmware" nonsense we went through with the Ender 3 in 2018? It can't be any more embarrasing than the source, so just release it.

  • @shinmai I followed your advice and read all the thread which I should have done in the 1st place followed your instructions to format card redid it and now all is ok many thanks for your help

  • @Daverobbo1904 I'm guessing it's one of the three things discussed at length in this very thread, that I distinctly remember pointing out had the pertinent information for making sure the update is succesfull.

    But to reiterate the points already made 3-4 times above by multiple users once more:

    • Format the SD card FAT 32 with 4096 byte sector size.
    • Unzip the files into the root of the SD card. There must be nothing on the SD card but the DWIN_SET folder, including all the files from the ZIP archive
    • If the update progress completes, but the numbers next to the files are all zeroes, the update has failed (there are multiple example images of both in the thread, I won't repost them, for this one you'll just have to go through the insurmountable obstacle of scrolling up a few messages)

    Again, this is not new info, it's all already in this thread multiple times in more detail. I highly recommend reading the thread (and reading threads in general before replying to them).

  • @shinmai when I updated the LCD update it went uploaded instantly no downloading sequence any idea why it may have failed please many thanks

  • @guivo The other Creality site I linked has all the versions available, still, including both the versions.

    I ran the update to give it a go and didn't have any issues, but went back to my own build of the community FW, because I want linear advance and some other things not enabled in the official firmware.

    @Daverobbo1904 reading this thread would be pertinent, sounds like you didn't update the LCD or the LCD update failed.

  • @shinmai I downloaded it installed it and its in Chinese any tips please the language icon doesnt seem to do anything thanks

  • @shinmai @Creality had a post with short life.

    I downloaded, found some weird charset encoding in the file and left a comment about that. When I went back a few hours later the post and the files had disappeared, so I didn't upload anything.

    The weird part is that the December 1st update overwrote the November 24th release, now both are gone and only available update is the 1.X, with no EEPROM use and other features.

  • Btw. in case you missed it (like I did) is out, but not on this website, it's only on one of the OTHER official creality forums.

  • There already is a repo, Creality just doesn't ever use it.

    Judging by how they keep releasing and deleting the firmware updates, and keep not releasing the source code in direct violation of the Marlin license, I'm not holding my breath on them adopting proper source code management and using the github issue tracker.
    But we can hope 🙏

  • @admin Question to Creality: Is there going to be open source repository for the firmware, where one can log bugs found and propose change request to speed up dev process?

  • @bucweat

    Same problem here, I just renamed these 3 files in the DWIN_SET folder to


    Then flash to LCD

  • @admin add again the source code would be highly appreciated

  • So, I updated my firmware to this version, even that i promised myself I would not. Because v.1.02 worked for me perfectly. Anyways I could not resist myself. So, things to note:

    1. When I first tried to update, by just having file "1бвCR-6SE - V2.0.1.2 Motherboard firmware.bin" on my SD Card. It got stuck and screen with progress and would not do anything, after power booting. I found that i lost my original firmware as well, and that is where I started swearing at myself for not waiting and trying on such fresh release. So, after doing couple of unsuccessful manipulations, I fixed it and got it to update. What I did was: first I downloaded firmware 1.02 and got it to flash to that, then I took "1бвCR-6SE - V2.0.1.2 Motherboard firmware.bin" and renamed it to "CR-6SE - V2.0.1.2.bin" and it flashed it successfully. Just thought I share this, if anyone else gets same problem.

    2. One thing that is really annoying about this firmware is screensaver, I do not know who thought it was good idea after 30 seconds to turn off screen. But it is really horrible feature, and you cannot even turn it off. WTF?!

    3. Translation to Russian, has some errors ... like for example where it should say "Prepare", it says "Cook". Creality if you need to help with Russian translation, you can send me res files, I will help.

    4. I noticed that zero level is gone higher now, so my level on 1.02 was 25 and it is now gone up to 35. It does not affect me in anyways, but just to note this changed.

    Everything else seems to be working as it was, for now I am still testing. Will update if I find anything else.

  • I installed the update (thanks everyone for the hints about the file system requirements on the screen update!!) and at first, all looks like it works fine. Then I tried something that Thomas Sanladerer mentioned in his latest video (😞

    Vase Mode
    And it has become worse. It just slows down to a crawl while pumping filament.
    Did the storage method for power interruption also change?

Log in to reply