CR-6 SE New Firmware Update 24th Nov

  • @shinmai I followed your advice and read all the thread which I should have done in the 1st place followed your instructions to format card redid it and now all is ok many thanks for your help

  • @Daverobbo1904 I'm guessing it's one of the three things discussed at length in this very thread, that I distinctly remember pointing out had the pertinent information for making sure the update is succesfull.

    But to reiterate the points already made 3-4 times above by multiple users once more:

    • Format the SD card FAT 32 with 4096 byte sector size.
    • Unzip the files into the root of the SD card. There must be nothing on the SD card but the DWIN_SET folder, including all the files from the ZIP archive
    • If the update progress completes, but the numbers next to the files are all zeroes, the update has failed (there are multiple example images of both in the thread, I won't repost them, for this one you'll just have to go through the insurmountable obstacle of scrolling up a few messages)

    Again, this is not new info, it's all already in this thread multiple times in more detail. I highly recommend reading the thread (and reading threads in general before replying to them).

  • @shinmai when I updated the LCD update it went uploaded instantly no downloading sequence any idea why it may have failed please many thanks

  • @guivo The other Creality site I linked has all the versions available, still, including both the versions.

    I ran the update to give it a go and didn't have any issues, but went back to my own build of the community FW, because I want linear advance and some other things not enabled in the official firmware.

    @Daverobbo1904 reading this thread would be pertinent, sounds like you didn't update the LCD or the LCD update failed.

  • @shinmai I downloaded it installed it and its in Chinese any tips please the language icon doesnt seem to do anything thanks

  • @shinmai @Creality had a post with short life.

    I downloaded, found some weird charset encoding in the file and left a comment about that. When I went back a few hours later the post and the files had disappeared, so I didn't upload anything.

    The weird part is that the December 1st update overwrote the November 24th release, now both are gone and only available update is the 1.X, with no EEPROM use and other features.

  • Btw. in case you missed it (like I did) is out, but not on this website, it's only on one of the OTHER official creality forums.

  • There already is a repo, Creality just doesn't ever use it.

    Judging by how they keep releasing and deleting the firmware updates, and keep not releasing the source code in direct violation of the Marlin license, I'm not holding my breath on them adopting proper source code management and using the github issue tracker.
    But we can hope 🙏

  • @admin Question to Creality: Is there going to be open source repository for the firmware, where one can log bugs found and propose change request to speed up dev process?

  • @bucweat

    Same problem here, I just renamed these 3 files in the DWIN_SET folder to


    Then flash to LCD

  • @admin add again the source code would be highly appreciated

  • So, I updated my firmware to this version, even that i promised myself I would not. Because v.1.02 worked for me perfectly. Anyways I could not resist myself. So, things to note:

    1. When I first tried to update, by just having file "1бвCR-6SE - V2.0.1.2 Motherboard firmware.bin" on my SD Card. It got stuck and screen with progress and would not do anything, after power booting. I found that i lost my original firmware as well, and that is where I started swearing at myself for not waiting and trying on such fresh release. So, after doing couple of unsuccessful manipulations, I fixed it and got it to update. What I did was: first I downloaded firmware 1.02 and got it to flash to that, then I took "1бвCR-6SE - V2.0.1.2 Motherboard firmware.bin" and renamed it to "CR-6SE - V2.0.1.2.bin" and it flashed it successfully. Just thought I share this, if anyone else gets same problem.

    2. One thing that is really annoying about this firmware is screensaver, I do not know who thought it was good idea after 30 seconds to turn off screen. But it is really horrible feature, and you cannot even turn it off. WTF?!

    3. Translation to Russian, has some errors ... like for example where it should say "Prepare", it says "Cook". Creality if you need to help with Russian translation, you can send me res files, I will help.

    4. I noticed that zero level is gone higher now, so my level on 1.02 was 25 and it is now gone up to 35. It does not affect me in anyways, but just to note this changed.

    Everything else seems to be working as it was, for now I am still testing. Will update if I find anything else.

  • I installed the update (thanks everyone for the hints about the file system requirements on the screen update!!) and at first, all looks like it works fine. Then I tried something that Thomas Sanladerer mentioned in his latest video (😞

    Vase Mode
    And it has become worse. It just slows down to a crawl while pumping filament.
    Did the storage method for power interruption also change?

  • Dear @bucweat

    Thanks for your feedback, we do test it again, you are right. Our people will update it again and we will upload and notice you next week.

  • @bucweat said in CR-6 SE New Firmware Update 24th Nov:

    I'm guessing there is a UTF8 issue somewhere...

    Definitely. It mostly works on Macs too, if you unzip directly to the SD card from a GUI tool (CLI unzip has the same issue as copying the files around), but this could all be worked around by just not having non-ASCII characters in the filenames in the first place.

  • Just an FYI this was my first firmware update so still learning 🙂 @shinmai you pointed me in the right direction...thank you 🙂

    @cweiss if you start the printer with the mainboard firmware updated but NOT the screen firmware then you'll only see Chinese language. I ran into that also. Now that screen firmware is properly updated I see english again and all is well.

    @shinmai my numbers don't look exactly like yours but they are mostly non-zero. I looked at the contents of the DWIN_SET folder and there are 3 .bin files but my update screen only showed one. On my first attempt I uncompressed the zip file in MacOS and then copied the files to the SD card with Windows. So I went back and tried again, but this time uncompressing and copying from Windows. Now I get the 003 next to the .bin files and after restarting the printer I have english and everything looks normal again. Whew!

    Here is my before image where I unzipped in MacOS note the 001 next to .bin:


    Here is the after image where I did everything in windows note the 003 now next to .bin:


    Just a guess but two of the .bin files have chinese character filenames which when I extract with Mac I can see the chinese just fine, but in windows not so much. I'm guessing there is a UTF8 issue somewhere...

    Anyway hopefully this helps someone...

    @admin when you guys post firmware updates it might be helpful to not just look for "END!" but also check the numbers next to the file types to make sure all of the expected files are correctly downloaded to the board. And maybe make sure the filenames don't have Chinese or other characters if that is going to muck up the process.

  • The "END!" message just means the bootloader has finished the update routine, it gives no indication on if anything was updated. When the update is finished, do you see numbers next to the file types like this:
    LCD display photo
    Or is it all triple-zeroes?

    Since you can interact with the menu, try to navigate to the factory reset option and run it, since you have no text at all, the LCD could be trying to load something that doesn't exist in it's memory and failing because of that.

  • I've updated the main board successfully, and it appears that I've updated the display too (I get the END!) Did this both with 16GB card formatted 16GB FAT32 with 4096K blocks and with two 8GB partitions each formatted FAT32 4096k blocks. Seems to have worked both times, but in both cases after I boot everything back up no language is selected and no words shown, just icons. When I try to select a language as shown in the video the display seems to lock up...I cannot select anything and the touch screen becomes unresponsive. It otherwise seems to work ok....I can level the bed and print, just have to do it based on ICONs only. The only text that does show up is filenames when selecting something to print. Hopefully @admin see this and can help...

  • Oh, okay. That's annoying, but not running ending gcode at all would be a bigger problem 😅 For some multi-color prints I have ending code that doesn't turn off the bed heater, so the part won't come loose while I swap filament, purge and prime the hotend and start the second print, and that would totally mess that up.

    I've been on the community firmware for a bit now in order not to drive my nozzle to the bed when cancelling prints on the first layer, so didn't know the official firmware did shenanigans like that.

  • @shinmai it did, but than added an extra reset, not sure about the exact sequence but as a visible effect CURA moved to present the result, the CR6 moved back the bed.

Log in to reply