Creality Ender-3 Pro FDM 3D Printer Windows 10 USB Serial Driver



  • Hi,

    I have looked for days but cannot find an answer to what driver should I use?

    https://www.creality.com/goods-detail/ender-3-pro-3d-printer

    I've checked the download page and am not sure what is meant by with adapter board and without adapter board, as in, I am not sure what this means.

    I have found the Ender-3 Pro SD Card File.zip on the download page, but cannot find any instructions on how to go about choosing the right driver for Windows 10.

    The software drivers folder has two folders: FTDI USB Drivers and WIN7, which has several folders including another FTDI USB Drivers folder, mac folder and windows folder.

    I presumed that I would need to use the drivers in the windows folder, but the update driver process doesn't find anything that it can use. So, I have tried doing it manually. Do I then select the ftdibus.inf or the ftdiport.inf? I tried port after reading the content.

    I then get to choose between USB Serial Converter, ... A, ... B, ... C, ... D, and USB Serial Port. The last one seemed to make sense, so I have tried that one. However, Windows isn't sure if it is the right one and neither am I. Choosing it appear to give me a USB serial device on COM5 and a USB serial port on COM6.

    However, the software cannot detect the printer.

    I'd like to update the firmware as a minimum but also print 'online'.

    So, I thought I'd ask on here for help (I am otherwise very pleased with the printer).

    Yours hopefully,

    Ian



  • Hi, some time ago I solved a similar problem, but in a different context. FTDI has started to add originality protection to its chips, and the w10 only allows original and certified drivers. So simply if you have a device where the original FTDI is it works ok. However, if a non-original FTDI is used in the device, you have a problem. But there is a solution to that as well. Check the original drivers in the W10. As you will definitely find on the net. Good luck.



  • This post is deleted!


  • Thanks for the reply. I tried it and Windows picked it up fine, unlike the other drivers, but the software still cannot see the printer. I am stuck.



  • Hi,

    I had the same issue and I downloaded this driver here.
    it worked great for me:

    http://www.wch-ic.com/download/ch341ser_exe.html

    Simon


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.