CR6-SE firmware seems in Chinese

  • I downloaded and installed the Dec. 3rd 2020 firmware, but it comes up in Chinese.
    Did I get the wrong version from them.?

    03 Dec, 2020
    CR-6 SE Upgrade Package V2.0.1.3_202012.7z

  • @optimusspurs did you manage to go back to the previous version?

  • I might have a suggestion if you haven't fixed it yet. I have the Ender 6 (I know its not the CR6-SE).
    I had the same problem I don't read Chinese and don't plan to learn.

    i looked on under CR Series and found Creality cr-6 se local language upgrade firmware.7z Dated 03/12/2020. when you unzip it you should find unzip that and put the contents on your SD Card.
    with power off. take apart you screen. and upgrade the screen firmware.

    A good video to watch is

    hope this helps

  • @ironside said in CR6-SE firmware seems in Chinese:

    do I unzip it and put that folder on the rood of the sd card


    I've formatted the card according to instructions and I've used 2 different cards with same result

    I would still double-check this. Maximum 16GB card (unless you FOR SURE know what you're doing, and repartition the card to make the correct allocation size possible) formatted to FAT32 and 4096 byte allocation size.
    Also use a GUI unzip program and unzip the DWIN folder directly to the SD. Copying the files around by hand with some file-managers will mess up the file names making for an incomplete update.
    Some users have reported that re-naming the problematic files works, too, but haven't tested that myself, so YMMV.

  • when I update the screen software, am I supposed to use the zip file, or do I unzip it and put that folder on the rood of the sd card?

    When I use the folder, I only get 000 for the files loading. I've formatted the card according to instructions and I've used 2 different cards with same result.

    When I use the .zip file, it seems to have worked, but I'm only able to select chinese language (no other languages appear).

    If i try to install an older version of the screen software, it fails on the last file with 000 and loads the v2 software that is on there now.

  • I have a CR6-SE and I installed new firmware vCR6SEV2013HWV452 and screen software v2.0.1.3 and I am unable to change the language. Pressing the language icon indicated in the instructions does nothing on the left half of the button (no beep), beeps and does nothing on the middle of the button, and beeps and returns to the main screen on the right hand side of the button.

    I am not able to produce a list of languages to select from. Very frustrating.

  • @StarLog said in CR6-SE firmware seems in Chinese:

    CR-6 SE Upgrade Package V2.0.1.3_202012

    I updated to the same and also got chinese and under control > Language there was no option to select any other language?

  • @shinmai Wasn't the case for me. I matched both updates and ended up with an unusable printer. Tried to roll back to the previous firmware for both the printer and the screen but still can't use it. The screen beeps when you push buttons but nothing happens. And there is no longer and temperature data showing. I'm an IT Professional for 20+ years so I do this sort of thing all of the time.

    Got the 8 GB SD card, formatted it as specified in the included instructions...

    Now I have a big expensive brick until someone helps me.


  • The most common reason for this is that you didn't update the LCD to match the firmware, or the LCD update failed.

    See the Firmware announcement thread for details on how to make sure you succesfully update the LCD firmware.

  • I had this same problem.. How do we revert back to the older version?

Log in to reply