E3 V2 layer shifting



  • The E3 V2 is my third 3D printer and I'm very happy overall but I'm having a strange problem. On certain prints, it seems either the stepper motors or drivers/control board overheat and then they have a problem stepping correctly. This leads to layer shifting constantly in a stair step like pattern. This is not a belt tension issue as the belt is not slipping over the gears but I have tried both tightening and loosening the belts. I also found someone else with a similar problem here.

    I first thought it might be an issue with the Gcode but I tried both PrusaSlicer v2.2 and v2.3RC-2. I also changed the model because why not but still the issue remained. I then thought it was an issue with the 150mm travel speed, so I changed it to 90mm but that didn't help. I also tried printing two calibration cubes that were 150mm apart but that did not cause the issue. I then tried a complicated spiral vase that wouldn't have any travel moves and again the layer shifts happened. Once a layer shift happens more will occur with increased frequency until the print completely fails. This is a tricky problem to track down because if the print is small enough or large but simple then the layer shifting does not happen.

    My printer is on a wood table in a room with no heat where the temperature ranges from 15-20c. So it should not be having an issue with overheating. I also noticed that on the first day this printer was completely silent besides the fan. On the second day I could hear a little bit of "driver" noise and that's also when I had my first layer shifting. On the third day the noise was like a normal printer, sounds like it's trying to dial up the internet.

    My pictures wont upload here but I have shared an album here.

    1. just a picture I took while it was printing.
    2. side profile that shows the printer printed fine for the first hour and a half.
    3. shows that when you immeditaely restart the print the layer shifting happens much faster now that the printer is already hot
    4. shows I tried a lot of different combinations of settings, slicers etc but still layer shifting after a while.

    The only picture I dont have is of the vase because I gave it to my mom and I would need to get it back but I might just print another one. I highly recommend people try to print this model with the stock "draft" profile that comes with PrusaSlicer 2.2 or 2.3 to see if their printer is also defective. Since mine is 3 days old I have just issued a return with amazon and should have a new one in a few days. I will post an update later on how the new printer behaves.



  • This is the same problem I am having. I have done all the steps requested here on this post, but still have the shifting. I have read about this on other website forums. The Ender 3v2 's that were bought in the last few months of 2020 seem to be having this problem. I purchased mine in November 2020.

    The only way I can print without layer shift is to prop open the mainboard case to allow for better airflow to cool the mainboard.



  • I am also having the layer shift issue with my ender 3v2. I have been trying to figure it out. I have read on another forum that the 4.2.2 board on these printers from late 2020 are overheating. People have used bigger fans, opened the mainboard case, etc. These things seem to work for a while but most say the problem comes back with time. The only real solution I have read about is installing the 4.2.7 board. This printer I have is 2 months old. I am sure that most printers that have this problem are around the same age.



  • @shadycuz I have the same problem with layer shifts as described in this thread.

    After opening the mainboard cover and adding an additional fan I have so far completed a 5 hour print and an 8 hour print without without layer shifts.

    One issue has remained though - after several hours the display acts as if I have pressed the button and enters a sub-menu. I am not sure if this is also related to the heating problem.

    PrinterMod.jpg



  • i have the same issues, couldnt even print 2 hours or so...
    the problem came after i build an "hero me Gen5" part cooling with 2x 5015 coolers wich i run at 33% cooling
    but after some research i red that the cooling from the CPU, scales with the part cooler, so after that the cooling was significant lower and i got a lot of shifting/freezing mid prints wich after the CPU board was cooled off i can resume with no problems
    i reinstalled it on the pins with the extruder cooler and it was 95% better (100% for the CPU cooling fan), now with this iam trying to put up 2x a 120mm fan in the bottom cover just to know that it wont overheat's, even when it will get hot inside the room it stands in.

    i report again if the fans are under there and how it works



  • I also have the exact same issue, ordered the printer in November, turned up early December. So far I've only been able to successfully print small prints roughly about the size of the calibration cube. Anything larger results in lots of layer shifting making the print unusable.

    I've completely stripped the printer down multiple times, relevelled the bed loads, ensured there are no blocks in the Bowden tube/hot end and fiddled about with almost every individual component to some degree or another, as well as trying multiple different settings in my slicer software and learned a lot about potential issues that didn't fix what I was seeing. But just can't seem to stop it from doing a 'thud' and resulting in lots of layer shifts. So far I've had a terrible experience with the Ender 3 v2 and it's been a massive waste of money, time and filament.



  • I have the exact issue. Ordered last of November as a Christmas gift. Received on 12-Dec, opened/built on 25-Dec. Small prints started ok, now having clicking/popping with all prints. Primarily larger ones. Tried all suggestions in this thread, still not printing perfectly. Exposing the mainboard to outside air and adding additional fans has helped, but not eliminated layer shift. In fact, I ran a "benchy" last night with a layer shift at the top.

    I hope Creality finds a solution to this issue. It is very troubling to buy a new printer and it simply does not work.



  • Has anyone found a fix for this? I can’t print anything over an hour before the “pop/thud” noise happens and I get layer shifts. It’s gets worse as the print goes on and happens randomly. I have sent two emails to cs@creailty with no reply. I don’t understand how they could sell this printer when it has overheating driver issues. I can’t even print a new mainboard cover so I can put a bigger fan on it due to the 3 hour print time and horrible layer shifts. I even tried printing with the part cooling fan @100% since I found out that that fan also controls the mainboard fan!



  • I received the 4.2.7 board as replacement from my reseller and printed a piece which took over 5.5 hours to print without any layer shift.



  • @Flowerin said in E3 V2 layer shifting:

    They say some 4.2.2 boards use 4988 stepper drivers which have caused a lot of problems for other printer brands as well, eg skipping steps etc. I personally have not removed the heat sink from one of my chips but if these chips are known for these problems and are indeed installed I expect we are only the top of the iceberg

    I thought (never checked) that 4.2.2 uses the tmc2208 and the 4.2.7 uses the tmc2225. These drivers are basically the same but different packaging. The packaging of the tmc2225 has better heat dissipation.



  • Came accros a video on YouTube of Th3D studio about the difference in v4.2.2 and v4.2.7 boards.

    They say some 4.2.2 boards use 4988 stepper drivers which have caused a lot of problems for other printer brands as well, eg skipping steps etc. I personally have not removed the heat sink from one of my chips but if these chips are known for these problems and are indeed installed I expect we are only the top of the iceberg



  • I have the exact same problem. Had the printer for a month and then the layer shifting started. I tried all the above solutions, but the cooling of the mainboard seems to work best. But it stil can't do big prints. It's sad, cause you don't expect that from a new printer. I don't know if it's a firmware thing, or actually a faulty mainboard/stepper driver.
    I hope creality can resolve this, cause this a unacceptable for a new printer.



  • I have exactly the same problem. Ordered the Ender 3 V2 just after Christmas and got it on the 28th.

    As soon as prints exceed a certain size in x/y at a certain point you hear the thud and it has shifted. Mostly on objects that are square.

    Everything is tight. Checked Vref voltages. Belts are running free. All axis slide freely when having the motors unplugged. Decreased flow.

    Nothing seems to help. Was having such high hopes for the Ender 3 V2 as my first printer but I'm now hoping I can return it.

    Kind regards



  • Dear @Sennevds

    For this issue, I will suggest you contact our after-sales support team. The email address is cs@creality.com



  • Hey guys just posting here to let you know I'm having this same issue with my CR10 v2. My issue didn't seem to be 5 or so hour prints but I get that THUD (shift) noise on my brand new printer about 8 or 10 hours in after it's been printing fine prior to the noise. If I pause the print so that everything is reset to zero as it does I can hear the THUD again like it's shifted back into place and resuming the print shows realignment. It's like at a certain point there's an internal issue that causes a jolt forward shifting it. My CR10 v2 has a separate control box and it seems to do it less with a desk fan blowing in to it but still does it. I've checked everything mentioned above more than once so I'm not exactly sure what's going on. Wish I could return this printer but The issue didn't present itself until I tried to print something big. Height didn't seem to have anything to do with it either, just overall size (print time)



  • @admin I've checked everything but nothing works. The only thing that helps is extra cooling. Or the thermal paste is not good or some bad drivers but it looks like this isn't solvable other than extra cooling(which shouldn't be a solution in my opinion)



  • Dear @diegomoreira00 @shadycuz @Sennevds @Ventura_Kid

    I have double-checked with our engineer, they give a check solution for it:

    When printing the model found the wrong layer, please follow the following 7 steps step by step to investigate.
    1, replace the print model, re-slice, set the print speed to 50mm / s, moving speed set to 60mm / s, re-print; exclude the impact of the model itself, if re-slice and replace the model printing can not solve the problem then carry out the second step, if the problem has been solved, please ignore the following steps
    2. check the synchronous belt tightness (move the belt back and forth to determine whether it is too loose or too tight), re-adjust the belt tightness, and then check whether the motor line is in good contact; re-plug the motor connection line, check no problem, re-print; if adjusting the belt tightness & unplug the motor connection line can not solve the problem then carry out step 3, if the problem has been solved, please ignore the following steps.
    3. motor fault investigation, test the resistance of the motor pins (red arrow and blue arrow pointing to the resistance of the two pairs of pins, if the difference is large, the motor has problems, need to replace the motor) if the replacement of the motor can not solve the problem then carry out step 4, if the problem has been solved without the fourth step.
    4. Z-axis movement problem: a. Z-axis screw problem, check whether the screw is deformed, remove the screw, put it on the horizontal glass surface rolling, see whether there is bending. b. T-bar nut problem, check whether the T-bar nut screw is too tight. c. Pulley profile problem, check whether the pulley/profile has depression deformation, if the problem can not be solved, then proceed to step 5, if the problem has been solved without the 5th step.
    5. Check whether the screws on the motor in the corresponding misalignment direction are loose, if the screws are loose, they need to be tightened and then reprinted, if tightening the screws does not solve the problem, then proceed to step 6, if the problem has been solved, there is no need to proceed to step 6.
    6. Remove the misaligned shaft end motor, reassemble it, and then print the model to see if the wrong layer, such as reassembly can not solve the problem, then proceed to step 7, such as the problem has been solved without step 7.
    7. Determine the mislayer motor, measure whether the corresponding mislayer axis direction drive voltage is 0.7-0.73, if it is (0.7-0.73), then adjust the voltage to 1.18-1.2, and then re-print. if the problem can not be solved, you need to contact the after-sales staff to deal with. cs@creality.com



  • Made 3 successful prints of 5+ hours with an open case. I’ll replace the mainboard cover as suggested on that Reddit post and add an extraction fan.

    I’ll contact the reseller too.



  • I have the same issue. My E3 V2 is from December (this week). I've checked all the screws and bolts, all the belts look good. No binding on the Z axis. It works good for an hour or two at the most now. I hear the clunk and see the level shifting. Any long program fails. I have also another clue that no one has mentioned. NOW it freezes up after a couple of hours. I have to power it down, and restart. Thats obviously a processor error from the main board. I'm asking the factory for a replacement. Perhaps we should be replacing it with a different model. Perhaps a new model has a different circuit board that's not bothered by heat.



  • Hi there,

    I’m having the same issue on a brand new e3 v2.

    Printing small pieces works without problems. Printing wider pieces (wider on x or y) causes small hiccups and as consequence layer shifting.

    I’ve opened the motherboard case and left a gap so air can flow freely as per others suggested.

    So far it seems to be working... I’ll update again after a couple of prints.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.