Problem with Z offset after upgrading to 4.2.7 board and BLTouch



  • Hello.
    I've had mine Ender 3 Pro for over 2 months and it was working perfectly. But it was too loud. So I ordered mainboard 4.2.7 with silent drivers, and along with it BLTouch.

    I installed it today, BLTouch installed with pin 27 board (as in instruction). Updated firmware with "4.2.7 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.1.2without adapter board TMC2225.rar".
    Printer woke up, I've done Auto Home and it's ok. Goes to X0 Y0, then to the center, probes 2 times for Z and stays in center.
    But the problem is showing in next step, when I want to set Z Offset. When I go to Prepare -> Move Axis -> Z, it won't react to knob turning, stays at 0 no matter what.
    Also, I don't have Z Offset setting in Control -> Motion, so even if I would want to set it "experimentally" I don't have such option.

    Situation is identical when I switch from installing BLTouch with pin 27 board to connecting it in board auto-leveling 5-pin slot. I switched the pins and connected it like in this thread, installed "4.2.7 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.3.1with adapter board TMC2225.rar" firmware and had exactly the same result. I've tried also installing firmware from linked thread, but printer would never boot up.

    What do I do wrong?


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.