Firmware Mishap

  • New user so I hope someone can provide a solution. I just got an Ender-3 Pro and tried to upgrade the firmware. It appears I have the V4.2.2 board that does not have the 6-pin adapter needed for most all of the firmware upgrade videos I've watched. I tried using the Ender-3 Pro_32bit_Marlin2.0.1-V1.0.1_BL Touch.TMC2208_Latest Firmware_0814.rar file. I don't have a BL Touch yet and after looking at an install video, I don't think you can plug it into the V4.2.2 board anyway.
    After that upgrade installed on my printer, I now can't do anything with it -- I can't even get it to home much less print. I tried installing a different firmware without BL Touch from the Creality website, but it seems to think its the same version and won't install over the other one.
    Is there any way to roll back or reinstall the original firmware? Thanks!

  • Hi, new user but simmilar problem. Ender 3v2, 422 board bought with v102 firmware. Updated to v111 BL touch but works poorly so ask creality service for latest soft. After update to v2084 got black screen so ask for a new scrin soft. Got DWIN from service but latest file inside was 03.2020 and after inserting to display slot it turns from black to blue and orange and stayed so. After reboot still black. I tryed to downgrade mainboard to 111 or 102 but still black (dont know if realized but used same card as for update with only one bin). Last attempt was to update by cura. Connect via usb, drivers seemed to install prop, display backlight on, BLtouch lights and pops out/in but cura cant see any connected printer. Service not responding for a few days. Any idea to help me??

  • Seems that I too am having this similar issue after installing my BL touch and trying to use either of these files
    14 Nov, 2020
    4.2.2 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.3.1with adapter board.rar
    14 Nov, 2020
    4.2.2 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.1.2without adapter board.rar

    If I use the "adapter" version it seems like I have full function, but there is a constant beep

    when I use the "w/out adapter" it will home, then got to position X162, Y117, Z10 and tell them to "home Z" but I cannot get it to adjust down. it will go UP. and I can move X and Y axis without issue.

    I have the 4.2.2 board with the ARM2 STM32F103RET6 chip

    I have renamed the firmware .bin file something new each time and i have done both quick and non-quick formats on my SDcard before loading the firmware file.

    any help would be greatly appreciated to get my printer working again

  • their is new firmware for the 4.2.7 that was released 14th November 2020 2 variants download the one that says no adapter card

  • Similar question, except for 4.2.7 board, on a Ender 3 PRO, NO BLtouch. It worked for a short time, then wouldn't boot up, so I tried flashing several different firmware flavors. I tried the only listing for 4.2.7, but that caused the beeper to go off, which I'm guessing is due to the BL touch feature, which I do not have.

    Based on the information above, my best guess was "Ender-3 Pro_32bit_Marlin2.0.1-V1.0.1_TMC2208_Latest Firmware_0814.rar". However, when I attempt a home or moving an access, I get NO motor movement. I know the connections are solid because I did a couple test prints before it wouldn't boot.

    So! @admin what is the correct firmware for 4.2.7 mainboard on an ender 3 pro, with NO BLtouch?

  • @Eldrod Hi, glad to see you are successfully working on it, and I make this post to be Pin post, that will help other people who have the same questions.

  • @SlackHacky said in Firmware Mishap:

    download it and rename to fixitfirmware.bin - put on a fat 32 formatted sdcard less than 8gb in size - if this fails to flash - try making 2gb size partition and format fat32 and firmware must be in root and not in a folder. Power off card in re power and wait.

    This really must be the criteria for this to work.

  • @SlackHacky That did it! I had tried that version of the firmware before, but I was using a 64GB SD card formatted exFAT. I copied the bin file to the original 8GB SD card and the firmware reloaded. Thanks for the help!

  • @Eldrod first off open bottom cover and find what board you have.... the number will be on it, they could be v1.1.5, v4.2.2 or v4.2.7 all fit the space.
    ALL require a different firmwares yes even v4.2.2 vs v4.2.7- Don't wildly flash wrong firmwares....

    firmware for v1.1.5 is a .hex file and is flashed by cable
    firmware for v.4.2.2 and v4.2.7 is flashed from Sdcard and will be a .bin file

    if you dont have a BLTouch don't flash the BLtouch firmware.

    for v.4.2.2 ender 3 pro no blT you need Ender-3 Pro_32bit_Marlin2.0.1-V1.0.1_TMC2208_Latest Firmware_0814.rar

    download it and rename to fixitfirmware.bin - put on a fat 32 formatted sdcard less than 8gb in size - if this fails to flash - try making 2gb size partition and format fat32 and firmware must be in root and not in a folder. Power off card in re power and wait.

  • This post is deleted!

  • Thanks, @timd1971 . No, I'm not the same person on Reddit. I have tried copying the other bin versions to the SD card, and have tried renaming the files several times from minor changes to gibberish, but once my EP3 upgraded to the Marlin 1.1.2, it will not recognize any other bin files when I reboot. It just comes up with the Ender logo screen. I've tried this about a dozen times.
    I did try to print one of the stock files from the initial SD card and the extruder moves to the XY position (lower left) then raises the Z and moves to position X162, Y117, Z10/??. Auto home does same thing. Once the extruder heats up, I get a "Home Z First" message and nothing else seems to clear it.
    I just ordered a BL Touch so I'm hoping having that will make the printer function, but it is strange that I can't reflash any other firmware now. (I did compile the basic Marlin 2.0.6 for this v4.2.2 board and could not get it to flash via the SD card either).

  • @Eldrod

    Ok, I think your the same person with this problem on

    Since u do not have the BLTouch yet, stick with the NON-BLTouch firmware for now.

    After you download it, uncompress the files. The .bin file u need to be concerned with.

    Rename the .bin file to something different. I.e. firmware01.bin

    Put on MicroSD card. Turn off printer, insert card, turn on ,wait for update which shouldn't take long... hope this helps.

Log in to reply