Ender 6 endstop issue.



  • Greetings all. First time Creality printer owner, picked an Ender 6 to start, not sure if I chose wisely though.

    Here is my issue.

    I got the printer assembled and tried to level the bed. The first thing that I noticed is that the Z=0 always seems to be where the bed is when it is powered on. I cannot go any higher after powering on. I can go lower but not higher. This is my first FDM printer that didn't know or did any figuring out where the Z=0 should be. I have a FFCP and a Snapmaker A350 and both knew where the Z axis should be.

    Second, I can manually move the bed up to the top where the nozzle just rests against the bed when the power is off. I will then turn the printer on and it remains in the position until I either go into the bed level screen or press the auto home button in the manual move screen. At that point the bed drops about 1cm from the nozzle. If I hit autohome again, it drops down by another CM. Each time this happens, Z=0 is reset to that position. I don't think there is enough that I an do with the bed leveling knobs to raise the bed by a CM. I also don't like that there is potential that every time I turn on the printer, I have to be mindful that the bed is all the way at the top.

    I also tried adjusting the Z axis endstop switch height as well as the adjustable rod on the back of the bed lift that will make contact with the switch. Nothing changes.

    Is this expected behavior from a Creality or Ender 6 printer? I have updated the firmware to ender-6-v1.0.4.9-endstop.bin based on some of the comments in other threads. Still no go.

    Please help



  • @OmegaPrinciple Did you get a Reciepe on your ticket, I got noting. So not even sure they got it and I have no number to reference too.

    What is your new hazardous issue ?



  • @GZZ They don't seem to interested in fixing things. Even though my issue with the Z-Stop is resolved, I have yet to get a response from them on my support ticket. It is coming up on a week. I was basically told by their support chat that they will get to it when they have time. My new issue is much more severe and hazardous. I doubt they will get to that one anytime soon either. I should have known better.



  • @admin I did a ticket at your link and got a successfully on submit. But I didnt get any mail to confirm I have a support ticket. So dont know if it gone though or not.



  • @OmegaPrinciple yes, dont delete it. You Leveling is stored in it. So if you have it on the SD card and its plugged in when turning the printer on, then it reads your last settings. If not in when turned on, it will use default (not aligned) settings.

    I guees it also has to be in, if you do any change to the leveling settings.

    Its the must dumb aproach I have ever seen and hope they change it in a newer firmware update.



  • @GZZ Is that the EEPROM.DAT file or whatever it is called?



  • @admin @OmegaPrinciple

    I found out my issue. When every I have done all my settings, they are saved on the SD card in a file that I previous had deleted for being "junk". But today I found out that if I started the printer without the SD card, then my Z-axis is off and return to "Default" and not aligned at all.

    Then turning it off and inserting the memory card and then turn it on will load the settings for my bed-level on start and will be align.

    I will raise a ticket, as this is a clear design fault, this kind of data should NOT be saved on a SD card, but in the firmware of the unit.



  • @GZZ If you take off the bottom cover of the machine, look on the left side of the board. One of the wires is labeled Z-. It should be all the way in with no silver showing. There is only one wire for the Z stop. if it is not plugged in or showing silver, use a pair of precision tweezers to push it in as far as it will go.



  • @admin I have created another ticket for my new issues. I do not know the ticket number because your system does not send a confirmation email.



  • @admin I did open a support request but have not had any response back. This was done on Jan 9. I would expect some kind of response by now. Now I have even worse issues and am considering returning this POS of a printer.



  • Dear @GZZ @OmegaPrinciple

    There is a specific platform for after-sales service, you are welcomed to leave your questions here, our people will feedback to you quickly
    https://www.creality.com/service-request
    73575064-b64d-41eb-a46d-274054422696-image.png



  • @OmegaPrinciple
    I have the same issue (I think). I have the BL-touch installed on my Ender 6. I can go to Settings -> Leveling and position the bed so it ready to print. But if I turn off the printer on the power button and starts it up again, then all my values are zero again and the beed is like 0.5-1cm from the nozzle.

    Also on the 1.0.4.9 firmware (BL-touch edition)

    Was this the same issue you had and what wire was loss ?



  • I have figured out the issue. The Z- axis wire on the mainboard was not making contact. I pushed it into the hole on the connector with a pair of tweezers. It now seems to work as expected.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.