Ender 3 v2 blank screen problem



  • I had recently got an ender 3 v2 and used it to print a lot of things and it worked great at printing them. I then heard something about how you can update the firmware to the latest so that it would fix the bugs that this printer sometimes had and so i tried it out.

    I got the firmware .BIN file from the creality page, gave it a short name, moved it to a blank SD card and put it in the printer. i turned on the 3d printer and the fans starts, the screen turns on but unfortunately it was blank and empty and it stayed that way even when i waited a couple minutes. I looked around online for anything on how to fix this, tried some of them out and they did not work. If anybody has a good detailed explanation on how to fix this i would very much appreciate it. And i hope no one else gets this problem because its not very handy to deal with



  • I have the same issue and its appears to be a common one from my understanding. I had an incompatible version of the .bin (firmware update file) on my SD card which bricked the whole unit. None of the online fixes work and I've tried them all. I've contacted Tech Support and am currently waiting for a reply.

    It appears there are some problems with this Bootloader functionality. For the first part, the filename of the .Bin file has to be unique each time a new one is applied. i.e. you cannot use Firmware.bin every time. Secondly, there is no sense checking that the .Bin file is compatible with the printer - it seems it just blindly loads it. Even the update for the screen doesn't appear to work, mine just shows an orange display when it should jump into life and show the Creality splash screen??

    My sense is that this will affect more people at some point in there Ender 3v2 journey and especially when they want to upgrade the firmware. The logic for the bootloader both programmatically and metaphorically needs to be fixed, and probably sooner rather than later.

    I hope they fix it soon. If I get an update I'll post it here - my sense at this stage is that I'm probably going to need new boards and that will likely be a long wait.

    Stay safe



  • Have you tried re-loading the old firmware?

    I had an issue and reloaded the original firmware to fix it.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.