Thermistor Error!



  • CR-10S Pro
    version 1.70.1

    I upgraded my CR hot end. Part of the processes is to remove the thermistor from the heat block. I did not want to damage the Thermistor but it would not pull out of the heat block. I decided to turn the printer on an heat up the heat block... I still could not remove the Thermistor finally I ended up shorting the Thermistor out. I glowed red hot burned out and I got an message on the counsole:

    Thermistor Error! Cycle Power! An issue exists with the bed or nozzle temperature sensor. Connect to serial monitor. If reading is 0, condition is open. If too high, condidtion is a short to ground. !![0_1598198880946_CrealityThermistorError1.jpg](Uploading 9%)

    Looking on line it was obvious that I needed to replace the Thermistor on the hot-end Nozzle... so I replaced the Thermistor and that worked fine... the new swiss hot end heated up perfectly.

    ... but then when I tried to heat up the Hot-bet Set Temp ... the Hot-bed temp showed 175 and when I tried to manually heat the hot bed to 70 the same error came up Thermistor Error! ... etc.. etc... I shut off the machine restarted and again tried to set 70 on the hot bed... and the same message came up Thermistor Error... So I thought the problem must now be because I also burned out the Thermistor on the Hot Bed.... so I replaced the Thermistor with the same Thermistor I used on the nozzle hotend. The Heatbed Thermistor looked in perfect shape but I decided to replace it anyways. But after I restarted and tried to set the temp manually on the hotbed the same error popped up.. Thermistor Error! What is also interesting is in the Set Temp screen it is showing that the Hot-bed temp: 175. I can say the bed temp is not 175. So it appears to me that there is an issue with the mother board. For whatever reason when I shorted out the nozzle thermistor I somehow shorted out the motherboard so that it thinks the actual Hot-bed temp is 175 when it is just room temperature.![0_1598198928118_CrealityThermistorError.jpg](Uploading 8%)

    My question is what should be my next step? New motherboard? Or is there aways to reset the motherboard so that it does not automatically think the heatbed is 175. I could put the old thermistor back in it looked fine... but I would still have the same error.



  • Hello, I am a 4th year electrical and electronics engineering student. I have a Creality CR10 MAX model 3d printer.

    Even though the printer is cold, the print plate temperature appears on the screen as 185 Celsius. Turning the printer off and on did not fix it. When I try to heat the build plate, I get a "THERMISTOR ERROR" warning. As a result of my research on the internet; I have come to the conclusion that there is a short circuit in the node to which the thermistor belonging to the printing table is connected. After disconnecting the thermistor connection on the motherboard of the printer, I measured the resistance of the thermistor from the end of the socket attached to the motherboard. It was 114 Kohm. (It means there was no short-circuit on the thermistor side or cables.) Then I restarted the machine without connecting the thermistor to the motherboard. Since the thermistor connection on the motherboard is open-circuit, I was expecting to see a temperature value in the minus. (because I knew that the minimum value should be measured when the thermistor is open) However, the build plate temperature seemed to be 185 degrees even if the thermistor was not connected. I did not do anything on the motherboard of the printer. But I guess the problem is maybe there. What should/can I do, could you please help me?



  • @sy2832 hello. were you able to solve this problem?? because i have same problem.



  • Dear @sy2832, For this question, I suggest you contact the seller, provide fault description and fault video to the seller. This is a unique after-sales problem, they will give you a solution depends. Thank you.


Log in to reply