Problems installing BLTouch firmware on Ender 3 Pro with 1.1.4 mainboard



  • I have the BLTouch 1.3 and I've been trying to update the firmware.
    The first problem was that the Youtube video showed the wrong orientation of the ribbon cable. Once I got that right and was able to successfully write the fuses, I loaded the firmware. However the firmware is labeled for 1.1.5 and 1.1.6; since there's nothing for the 1.1.4 board (I got mine less than a year ago) I went with that.
    When it finished writing the beeper began beeping continuously. I turned off the printer and completed connecting the BLTouch hardware as directed in the video here: https://www.youtube.com/watch?v=2B4qdKdqJj4
    Now I get a blank screen.
    I have tried writing the firmware again, and also tried other firmware builds such as Marlin, and I get the same result.
    Any suggestions?
    I've used both the firmware from the Creality site and the Dropbox site (which is the only working progisp I found - the one from the creality site crashes on startup).
    I've tried Ender-3 Pro1.1.6BLTouchV3PowerLossContinueEnglish.hex (from Dropbox)
    and Ender-3 Pro1.1.6BLTouchV3.1PowerLossContinueEnglish.hex (from Creality)
    and get the same result.
    The display cable is inserted correctly in the adapter board (it's keyed) and there's only one way the adapter board goes on the main board.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.