Help request - Ender 3 pro extruder running backwards.

  • Hey guys,

    Just wondering if I could get some help here. I have the ender 3 pro V1 which is about 6 months old maybe less. I bought a cheap direct drive upgrade kit from Amazon but I struggled to get decent prints out of it because I think it was made by a monkey wielding a sledge hammer. but everything "worked" ok, just print quality was bad and lots of nozzle jamming issues. So I decided to upgrade to the Micro Swiss all metal direct drive kit which I have installed but noticed that the extruder is on the back of the plate on this one (it was on the front of the plate on the cheap amazon one) and I'm having the problem of when I ask it to extrude it actually retracts, so instead of printing it just unloads the filament.

    Now I thought this would have been an easy fix, so I googled it but seems others with this issue are getting lots of different "fixes" such as below.

    1. changing the Esteps per mm to say -130 instead of 130.
      Sadly, using the dial on the unit, its not possible to get it to go negative.

    2. Run a G code command to change Esteps to a negative number.
      This just set Esteps to 0 and therefore wouldn't move the extruder at all.

    3. Swap wires connected to pin 1 and 4 round to reverse direction.
      This resulted in the stepper motor 'thunking' and then doing nothing, swapping wires back again returned the extruder to running fine, but backwards still.

    4. Reverse the whole plug either on the stepper motor or on the control board.
      The plugs appear to be JST connectors which can only be inserted into the Stepper Motor or the Control Board in one direction, making it not possible to reverse the whole plug.

    So I'm a little stuck on how to fix this so i can use the printer again. Hoping someone here may have had a similar problem, or knows of a way i can get this swapped round

    Thanks in advance for your time.


  • @Therealfury You're welcome! I also prefer this quick and dirty solution, way faster and durable than a firmware change. Before inverting the cables, check with a multimeter which cables are connected to the same set of bobines, and be sure to reverse only one pair, as explained here:
    I suspect, but I might be wrong, that the cables 1 and 4 you tried to swap belong to different bobines, and that could lead to have an identical voltage applied to the opposite sides of each bobine, thus the current not flowing.

  • @Stefano Thanks for your reply. I have ordered a replacement stepper motor cable and once this arrives ill go ahead and try the harsh approach. I don't have the first clue about compiling firmware, so until I find the time to teach myself (or find someone that could compile some firmware for me) ill stick to the less technical approach and see how that goes. Fingers crossed.



  • @Therealfury
    A harsh solution could be cutting the four cables of the motor and flip them, as if you were flipping the connector. If you have already done some soldering it should be pretty easy.
    A more elegant solution is compiling the firmware by yourself and set the extruder to run in opposite direction. I'm terrible at compiling programs, but if you are familiar with the subject that's probably the best way to reverse the stepper motion.

Log in to reply