ATTENTION: Creality BL Touch Application Notice

  • Do you have same instruction manual for BLTouch for Ender 3 V2?
    As far as I know the motherboard of V2 has free slots to connect BLTouch.


  • When will the official BL touch for the Ender 3 v2 be released? I'm waiting for the official version to upgrade my printer.

  • Replying to myself here...I have my Ender 3 Pro with 4.2.7 board and 1.3 BLTouch working.
    For those who may follow...
    Put the 3-pin BLT connector into the BLT connector on the 4.2.7 board, on the left side. You will likely have to swap the blue and red wires to match the pinout on the 4.2.7 board connector (I did).
    Then remove the -Z limit switch connector from the board, and put the 2-pin BLT connector into the -Z limit switch connector on the board.
    So, yes -- part of the BLT is plugged into the BLT connector on the board, and part is plugged into the -Z limit switch connector.
    Then use the firmware from here:
    Flash the firmware, boot it up, set the z-offset, and you're off and running.
    Bit thanks to Flavio (whose github repository for the firmware .bin file is linked above), who helped me work through using the -z limit switch connector for the BLT to get it all working.
    I'm printing and auto-bed-leveling on the Ender 3 Pro with 4.2.7 board now. All good.
    Hopefully Creality will release a firmware version that works correctly soon, but until then, the Marlin 2.0.6 version above is the way to go.

  • @SlackHacky thanks for the info, I've tried Creality's official firmware with a 1.3.1 BLTouch and a 4.2.7 board (tried using both the adapter block for the display and the BLTouch port on the board) -- neither works.
    Do you have a link to a .bin file for the complied bugfix206 you mentioned? Or a link to where I can get it?

  • I have an Ender 3 Pro. I upgraded to the 32-bit board, version 4.2.7, last week. It came with the firmware pre-flashed, and it worked without any problems.
    I received a BLTouch v1 today - an officially labeled and branded Creality version. Flashed the firmware recommended ( 4.2.7V-Ender-3 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch-TMC2225.bin). Before wiring up the BLTouch, the machine booted but the buzzer is on constantly.
    Tried both methods of connecting: first I used the adapter block for the display port included with the BLTouch v1, removing the Z-axis switch, and plugging the BLTouch into the adapter board. The display would not come on.
    Tried the wiring above, using the BLTouch port on the 4.2.7 board, swapping the blue and red wires in the black 3-pin BLTouch connector and trimming the 2-pin connector so it fits in the BLTouch port on the board. In that configuration, the machine boots, the BLTouch initializes (red light, pin pops in and out a couple of times). But when I do an Auto Home, the machine starts to Auto Home, then moves to the center of the build plate, and displays "STOPPED" on the display. And the buzzer is on constantly again.
    I would sure appreciate some help getting this working. The worst part is that I can't just unplug the BLTouch and re-flash the 32-bit 4.2.7 non-BLTouch firmware -- it's not available on Creality's site.
    Thanks in advance for any help.

  • @Cristian . Yes, I have been running that way for a couple of months. I was using the original release of the software and then switched to smith3d firmware about 3 weeks ago when I didn't see a creality release. I have not tried the creatlity firmware yet.

  • @dkfauth you get it to run on the dedicated port? how?

  • @frated The BL-Touch acts as the z-axis limit. It will set the z=0 when it probes. The printer wont go past that unless you set the z-offset to a negative value. When you tune it after the auto level you will need to set the offset which should be a negative number but a small one. With the bracket I modeled and printed my z-offset is only .30mm. Your offset will depend on the bracket you used to install the BL-Touch.


  • @admin
    The BL Touch unit retracts during normal operation, and is extended well beyond the nozzle during bed leveling. Is the Z-axis limit-switch still valuable for preventing catastrophic bed collisions if it is adjusted properly after manual bed leveling? (as long as it is low enough to allow a good first layer and high enough to prevent more than just glancing contact)

  • @daviesj
    Thanks for the concern. The machine has been used for less than 12 hours. It's been out of the box for a week. There is some dust on the machine now from some CNC routing without enough suction at the dust shoe. I need to give it a good vacuum before I use it again.

  • @frated It looks like you have something wrong with your x-axis. The wear on your guide wheels is very excessive. You might want to check on why they are wearing so badly and also replace those wheels for smoother operation.


  • @jiva The BL-Touch is a replacement for your z-limit switch. You should unplug the z-limit switch once you install the BL-Touch. I removed the original z-limit switch completely from my Ender 3 V2 after I installed the BL-Touch.


  • Dear @jiva

    Yes, you are right. Please unplug the Z-limit.

  • @admin If we are using the 5-pin connector, would we need to unplug the Z-limit connector?

  • @frated
    BLTouch v1 mount on Ender 3 v2

    • Take the screw out of the heater assy housing in back as shown.
    • mount the BLTouch with mount without that screw
    • use a scribe, nail, something scribe the mount where the screw hole is
    • drill the hole that you marked.
    • reassemble with the new screw through the mount and into the housing as shown.

  • Dear @dkfauth
    If your bltouch interface is 5-pin, it needs to be directly connected to the BLtouch reserved interface. If your bltouch interface is 3-pin and 2-pin, please refer to the video to connect

  • @admin


  • @dkfauth I just installed the Creality BL touch kit v1 on my new Ender 3 v2. The wiring guide showing the 3pin dupont and 2pin XHF connector jammed into the BL touch XHF port on the board is correct. I cut the connectors off and put a proper 5pin XHF connector on because I had an extra around. A couple of observations:

    1. The wiring locations are correct.
    2. The Z limit-switch does not need to be disconnected.
    3. The v1.1.1 firmware works
    4. The updated v1.3.1 firmware did not work (though I may try again now that the v1.1.1 is working)
    5. The hole closest to the heating block is not in the correct location for the v2. I mounted it for placement, scribed through the screw hole and drilled a new one without much difficulty. The mount is soft metal.

    At some point, I may revise my setup and do it with a proper kit. But, for a beginner with a center-low glass bed, this has solved my first layer problems.

Log in to reply