ATTENTION: Creality BL Touch Application Notice

  • Time: August 27th, 2020
    Dear Valued Clients,

    we would like to appreciate you for consistently support to Creality 3D for so many years, and we feel deeply honored to serve you with printers, printer parts, and filaments. For providing you with further excellent service and products, we would like to make a brief declaration of BL touch as below:

    1. The BL Touch kit sold by Creality applies to all 8-bit motherboard 3D printers,

    2. If currently, BL touch kit wants to compatible with a 32-bit motherboard 3D printer, please check BL Touch Introduction.pdf in the Ender-3 list to do up-gradation.

    3. Creality has already published new BL touch kit to compatible with a 32-bit motherboard 3D printer, please check Following documents in our website:

    Ender-3 - Marlin2.0.1- V1.3.1- BLTouch.bin
    Ender-3 - Marlin2.0.1- V1.3.1- BLTouch - TMC2225.bin

    Ender-3 Pro - Marlin2.0.1 - V1.3.1 - BLTouch.bin
    Ender-3 Pro - Marlin2.0.1 - V1.3.1 - BLTouch - TMC2225.bin

    Ender-3 V2-Marlin-2.0.1 - V1.3.1 - BLTouch.bin
    Ender-3 V2-Marlin-2.0.1 - V1.3.1 - BLTouch - TMC2225.bin

    Ender-5 - Marlin2.0.1 - V1.3.1- BLTouch.bin
    Ender-5 - Marlin2.0.1 - V1.3.1- BLTouch - TMC2225.bin

    Ender-5 Pro- Marlin2.0.1 - V1.3.1 - BLTouch.bin
    Ender-5 Pro- Marlin2.0.1 - V1.3.1 - BLTouch - TMC2225.bin

    This is the video of 32-bit motherboard install the BL touch tutorial for your reference:

    We will continue to provide you with the quality products and service which you've come to expect and even more.

    If you have any questions or concerns, please don't hesitate to contact our sales representatives or email us at

    Thank you,
    Shenzhen Creality 3D Technology Co., Ltd,

  • @beejack
    agreed. The Marlin bugfix fork is great. But, it's for people who want to edit their own parameters and do more in depth customizing. I enjoy that. I've been trying to stick to Creality specific releases in my comments to make it easier for those just getting into Gcode controllers to have an easy time with updates. I'll be glad to hear about anything new and exciting you find along the way though! Thanks.

  • @frated
    The latest marlin firmware buxfix 2.6.x works with the BLTouch port as well except that the Z offset in tune is broken.
    It's the version I've been running for the last week or so without issues.

  • @admin
    Thank you. I was able to wire the BLTouch V1 directly to the available port by wiring a proper JST-XHP 5pin connector. No additional riser/adapter boards required. All works well. I noted that the V1.3.1 firmware did not work correctly for me. I was able to flash the V1.1.1 firmware with update of control board and remote controller display. All is well. 🙂 🙂 🙂

  • There seems to be a few different ways to connect the BL Touch to the V2 depending on where you obtain the firmware

    Creality - 3 pin plug to adapter board, 2 pin to Z limit port(as per the ender 3 and pro)
    Marlin - both to BT touch port but three pin requires two cables swapping (red and blue on the offical v3.1)
    Other builds such as by flavio use both the BL Touch ( again swapping the two Cables) and the Z limit port

    It can be quite confusing.

    I would suggest deciding on one source for the firmware and sticking to it until Creality get their act together and release the official BL touch.

    I've tried all three ways and am now sticking with the Marlin firmware.

  • Do you have same instruction manual for BLTouch for Ender 3 V2?
    As far as I know the motherboard of V2 has free slots to connect BLTouch.


  • When will the official BL touch for the Ender 3 v2 be released? I'm waiting for the official version to upgrade my printer.

  • Replying to myself here...I have my Ender 3 Pro with 4.2.7 board and 1.3 BLTouch working.
    For those who may follow...
    Put the 3-pin BLT connector into the BLT connector on the 4.2.7 board, on the left side. You will likely have to swap the blue and red wires to match the pinout on the 4.2.7 board connector (I did).
    Then remove the -Z limit switch connector from the board, and put the 2-pin BLT connector into the -Z limit switch connector on the board.
    So, yes -- part of the BLT is plugged into the BLT connector on the board, and part is plugged into the -Z limit switch connector.
    Then use the firmware from here:
    Flash the firmware, boot it up, set the z-offset, and you're off and running.
    Bit thanks to Flavio (whose github repository for the firmware .bin file is linked above), who helped me work through using the -z limit switch connector for the BLT to get it all working.
    I'm printing and auto-bed-leveling on the Ender 3 Pro with 4.2.7 board now. All good.
    Hopefully Creality will release a firmware version that works correctly soon, but until then, the Marlin 2.0.6 version above is the way to go.

  • @SlackHacky thanks for the info, I've tried Creality's official firmware with a 1.3.1 BLTouch and a 4.2.7 board (tried using both the adapter block for the display and the BLTouch port on the board) -- neither works.
    Do you have a link to a .bin file for the complied bugfix206 you mentioned? Or a link to where I can get it?

  • I have an Ender 3 Pro. I upgraded to the 32-bit board, version 4.2.7, last week. It came with the firmware pre-flashed, and it worked without any problems.
    I received a BLTouch v1 today - an officially labeled and branded Creality version. Flashed the firmware recommended ( 4.2.7V-Ender-3 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch-TMC2225.bin). Before wiring up the BLTouch, the machine booted but the buzzer is on constantly.
    Tried both methods of connecting: first I used the adapter block for the display port included with the BLTouch v1, removing the Z-axis switch, and plugging the BLTouch into the adapter board. The display would not come on.
    Tried the wiring above, using the BLTouch port on the 4.2.7 board, swapping the blue and red wires in the black 3-pin BLTouch connector and trimming the 2-pin connector so it fits in the BLTouch port on the board. In that configuration, the machine boots, the BLTouch initializes (red light, pin pops in and out a couple of times). But when I do an Auto Home, the machine starts to Auto Home, then moves to the center of the build plate, and displays "STOPPED" on the display. And the buzzer is on constantly again.
    I would sure appreciate some help getting this working. The worst part is that I can't just unplug the BLTouch and re-flash the 32-bit 4.2.7 non-BLTouch firmware -- it's not available on Creality's site.
    Thanks in advance for any help.

  • @Cristian . Yes, I have been running that way for a couple of months. I was using the original release of the software and then switched to smith3d firmware about 3 weeks ago when I didn't see a creality release. I have not tried the creatlity firmware yet.

  • @dkfauth you get it to run on the dedicated port? how?

  • @frated The BL-Touch acts as the z-axis limit. It will set the z=0 when it probes. The printer wont go past that unless you set the z-offset to a negative value. When you tune it after the auto level you will need to set the offset which should be a negative number but a small one. With the bracket I modeled and printed my z-offset is only .30mm. Your offset will depend on the bracket you used to install the BL-Touch.


  • @admin
    The BL Touch unit retracts during normal operation, and is extended well beyond the nozzle during bed leveling. Is the Z-axis limit-switch still valuable for preventing catastrophic bed collisions if it is adjusted properly after manual bed leveling? (as long as it is low enough to allow a good first layer and high enough to prevent more than just glancing contact)

  • @daviesj
    Thanks for the concern. The machine has been used for less than 12 hours. It's been out of the box for a week. There is some dust on the machine now from some CNC routing without enough suction at the dust shoe. I need to give it a good vacuum before I use it again.

  • @frated It looks like you have something wrong with your x-axis. The wear on your guide wheels is very excessive. You might want to check on why they are wearing so badly and also replace those wheels for smoother operation.


  • @jiva The BL-Touch is a replacement for your z-limit switch. You should unplug the z-limit switch once you install the BL-Touch. I removed the original z-limit switch completely from my Ender 3 V2 after I installed the BL-Touch.


  • Dear @jiva

    Yes, you are right. Please unplug the Z-limit.

  • @admin If we are using the 5-pin connector, would we need to unplug the Z-limit connector?

Log in to reply