Ender 3 Pro BLTouch with transfer board firmware on 32 bit 4.2.2 mother board not working properly



  • I bought the creality bltouch kit linked here(https://uk.banggood.com/Creality-3D-Upgraded-Version-BL-Touch-Heated-Bed-Auto-Bed-Leveling-Sensor-Kit-For-Creality-V1-Mainboard-Including-Ender-3-or-Ender-3s-or-Ender-3-Pro-or-CR-10-3D-Printer-p-1435882.html?cur_warehouse=UK&rmmds=search), but didn't realise that I had a V2 motherboard. So I tried using the extension cable with some gpio jumper cables to attach it to the motherboard. First print worked out fine, but the bltouch was very intermittent, sometimes working sometimes not. So I tried using the transfer board installing the bltouch like you would with a V1 motherboard. I noticed that the firmware file said temporary on it, but installed it anyway thinking 'It can't be that bad'. It was that bad. The firmware seems to randomly detect me clicking on the knob every 30 seconds or so, I have been very lucky so far as it hasn't by mistake clicked on anything which would have broken the printer. But even worse, the bed levelling doesn't really work at all. the probing runs fine, but the printer then proceeds to completely ignore it. I can't find a previous update anywhere, and I know that technically I shouldn't be using the transfer board with the V2 motherboard and I would be absolutely clueless trying to make my own firmware, but I think that the firmware should be a lot less janky for it to be the only available version on the download page (creality.com/download) supporting the transfer board on the V2 motherboard. It would be amazing if someone could send a previous, working version of the firmware or if I'm doing something wrong, pointing that out to me.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.