How do I set Z offset correctly after installing bltouch?



  • Ender 3 Pro, newly installed 4.2.7 main board, newly installed bltouch from creality. Running the Ender-3 Pro- 4.2.7-Marlin2.0.1 - V1.1.2 - BLTouch - TMC2225.bin firmware - the one for no adapter board.

    I can't get the Z offset set. The included instructions are vague at best, and I can't find any videos or other guides on how to do it.

    What I think i'm supposed to do - run Auto Home. Then go into Control>Bed Leveling>Probe Z Offset and then adjust that so it's a paper's width away from the print surface. Adjusting that setting works to move the print head up or dawn, and I can get it fairly close to the print surface, but at-9.900 it stops moving or incrementing further, and it's not all the way down where it needs to be.

    It all seems to be working correctly otherwise - if I start a print it will do the bed leveling routine and then start printing, although it's up in the air when it does, so needs to be aborted.

    Any ideas?



  • @sduck The BL Touch should be installed so it activates with the print nozzle approximately 3mm above the bed. If you need 10mm+ offset then check the BL touch is installed at the correct height. Otherwise check that 10mm dialled up = 10mm in distance, if not your z calibration could need setting.
    I found setting the offset hit & miss and that repeatedly Homing and moving Z to 0mm then tweaking the offset before homing again........ eventually gave me the correct offset.



  • this forum is garbage, no help at all. Check on reddit.



  • Hello Sduck,

    u still fixed ur problem? i got the same Problem ;( i go Crazy with this.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.