Ender 5 Pro - latest firmware update



  • My Creality Ender 5 Pro was delivered last week. After aseembly and startup, I receive the Error message: "TMC Connection error" and the printer did not allow me to navigate through the menus or perform any action. The model sticker is E5ProW202J0715063 and I also confirmed that the chipset inside is the V4.2.2 on the board. I went to the creality website (https://www.creality.com/download/32) to update the firmware using (V4.2.2-Ender-5 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch.bin) release on 29 Aug 2020 - and the TMC connection error has gone away, and I have tested the bed and nossle heating, x/y/z stepper seem to be working - however the Printer is not able to print when I load the test prints that came with the printer. I also can't level the bed as it keeps going offsetting the bed when I go to that function. The speaker on the LCD display also makes a very loud noise ( the clicking of the button constantly), which is unbearable. Is this related to me BLTouch ( I don't have it), if so where can I get the latest firmware without BLTouch for this model. I found some articles on the internet that have reported these issues with the printers shipped recently with 32-bit firmware was only compiled for TCM2208 stepper drivers, while the board I received may require HR4988 stepper drivers. Thanks





  • Hi @admin,

    I just tried to install the new firmware and it was able to load this time. however the menu is different and there is no obvious menu to level the bed. Can you send me the documentation? thanks



  • Hi @admin ,
    I looked at this solution you posted on that topic already, I tried updating the firmware with the "Ender-5 Pro- Marlin2.0.1 - V1.0.1 - Endstop.bin" update and the result is a blank screen - so no boot up - so this firmware file you posted did not seem to work for me.
    Is the (V4.2.2-Ender-5 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch.bin) release on 29 Aug 2020 not a later version of the firmware?



  • Dear @Trung,
    This is the same issue post, and there are solutions here, please check. Thank you.
    https://forum.creality.com/topic/122/ender-5-pro-tmc-connection-error/3


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.