Ender 3 V2 - screen blank after LCD firmware update



  • My Ender-3 V2 came with the newer 32-bit mainboard (version 4.2.2). I successfully updated the firmware of the mainboard. I then attempted to update the LCD's firmware. That seemed to go OK. (The screen switched color to orange / red.) Then I powered the printer off, withdrew the SD card from the LCD's slot, reconnected the LCD cable, and turned the printer on. However, the screen didn't come back on.

    The printer's fans come on, and the LED light inside the control board area lights up, but the LCD screen stays dark (like not on or getting no power).

    I think the LCD firmware files I first tried (DWIN_SET from Marlin Github) were not right somehow. I then downloaded the DWIN_SET files from here on the Creality site (dated 2021-03-08). However, nothing I try gets anything except a black screen on the LCD.

    I've tried two different ribbon cables. I've tried two different SD cards. The cards are always freshly formatted with nothing on them but the firmware files. The cards are always formatted only to FAT32, and always only 2GB cards. I am careful to always unplug the printer before each attempt. I've made sure there is only one partition on the cards. I've tried the cards in the LCD slot, the mainboard slot, and even tried with a card in each of the two slots.

    I've begun to think I have either a bad LCD board or a bad mainboard. All help greatly appreciated.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.