Ender 3v2 stuck on Creality Startup screen



  • My screen froze after stopping a print.
    I rebooted but then the screen got stuck on the Creality startup screen.
    Found Forum post where there was a black screen, and the response was to update the firmware for the main board and the screen which I did. The screen update goes to the orange screen, but when I try to update the main board it gets stuck on the Creality startup screen every time.

    Please can someone assist with further trouble shooting?



  • Hi!

    I don't know if you have solved your solution, but with me, it was a thermistor problem. I disconnected the thermistor from the hotend and checked the insulation between the thermistor wires. After that, the printer started up properly.



  • @keith
    To update the firmware, both the motherboard and display must be updated

    1. Refresh the motherboard firmware tutorial:
      https://www.youtube.com/watch?v=AKIfwPgN0qs&feature=youtu.be
    2. Refresh the display firmware tutorial, format the sd card, then copy the display firmware to the sd card, then insert the sd card into the card slot of the display, then the display will automatically refresh the firmware, and the display will display orange That is, the refresh is successful
      https://www.youtube.com/watch?v=Jswzrh2_ekk
    3. Please re-plug the display cable, unplug the nozzle thermistor, if the same failure still occurs, please provide the boot video and printer manufacturing code
      Ender-3 V2(2).zip


  • @admin having the same issue but I am not sure where to start. Stuck on logo screen when not updating. Put card in with firmware update files and screen is orange. Stop and remove card, restart returns to stuck logo screen.



  • Dear @chrismark

    Please send the voltage test video to your seller, if it is judged that the motherboard is faulty, they will arrange a replacement for you. Hope this will help you. Thank you.



  • I did that twice. I tried to revert back to and older version with a name that was unique with a timestamp. Then tried to update to the latest again with a unique name. Still nothing.
    I used this video https://www.youtube.com/watch?v=7wxkfzKuXFU and tested the boards and some of the points on the board do not get voltage readings.



  • Dear @chrismark, change the firmware name and try to refresh it again.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.