Another BL Touch Problem



  • Just fitted my new antlabs bl touch. updated firmwear and have the correct auto level screen. However when I power printer up, bl touch probes twice red light stays on. go to level screen. bed drops down about 10mm hotend moves to corner then moves to just off center. bed drops down 10mm again. bl touch probe moves twice and red light goes out. then thats it. press measure nothing happens. press z stop up and down arrows. nothing. Any thoughts as to what I have doing wrong?



  • @telephasic Yes. Very frustrating. I swapped the e-plug and the z-plug around on the board to check if was a wire or motor fault, move the z axis from the control panel and the e-motor runs correctly in both directions. press the feed button on the panel and the z motor does the joggle back & forth. So I'm guessing its something with the board. I'll send an email to creality and see if they can help, but I bought the board thru Banggood, soo.... all i can do ask.



  • @CrankyEv weird. mine is workin with a wch.cn CH340 driver but i see it's verson 3.4.2014.8 compared to 2.8.2007.09 from creality.. i must have gotten it from somewhere else for another device but i dont remember where. creality should really get new ones, or at least some that work.

    hmmm.. so the y stepper, y wire, and y & e motors all seem to work if i understand correctly.
    what about trying the e wire+e motor on the y stepper (rule out the e wire now)?
    or y wire + y motor on the e stepper? (focus on the stepper)

    i really thought it would have been those e-steps (yes stepping values: higher number = more rotation for same requested movement). now just shootin in the dark. maybe customer service will help. pretty frustrating though.



  • @telephasic . yes. got the printer connected. ended up needing the CH341 drivers. sent the m92 command and got back the same values as you had m92 x80.00 y80.00 z400.00 e140.00. Are they the stepping values for the motor? Changed the E value down to 80 and up to 180, motor just joggles slower or faster. I've checked the driver voltage on the board and tested at 0.915v. Adjusted up to 1.2v, same as x & y steppers, no luck.



  • @CrankyEv Well I found a link to CH340 drivers:
    https://forums.creality3dofficial.com/download/software/
    This does have the .INF file, and looks the same as what came on my SD card.

    Wonder if you have some other things plugged in, that are showing up as the other USB Serial Devices? Does that one listed under Ports show up only when plugged to the printer? If you can be sure it's the printer and not something else, you might try to Update Driver on that one.



  • @telephasic tried that, no luck. this is the screenshot of the device manager.
    Screenshot 2021-06-28 162500.png
    plugging cable in/out shows its connecting, update driver comes back with-
    Screenshot 2021-06-28 162619.png
    have tried both the CH340 and the FTDI drivers from the sd card and from support.th3dstudio. one thing I did notice that the driver folders dont have any INF files in them. from what i can find on the net, keeps mentioning these type of files when updating drivers. followed youtube tutorials on loading these two drivers, still no luck. might take everything to work and contact the tech expert and get him to have a look.



  • @CrankyEv Nah I agree, no need to get a pi just to try this. But once you are up and running, it is one of the best add-ons to have in general, and more like $50 to get started.

    Anyway, I need a bit more to go on here. What program are you trying to connect with? I'm not sure if there is anything on the SD card that has a terminal. What is saying the drivers are loaded?

    When you plug it in, it should make the happy chime. In Device Manager, if the driver really is installed and working, you should see something like this under Ports:
    4c5dd552-3aec-4fd2-a01b-38fb8b0eae90-image.png

    If it's not showing, it might be an Unknown device under Other devices. You can tell if it's the printer by unplugging it (it should disappear), and plugging it back in (it should re-appear). Right click the Unknown device, and choose Update Driver Software. Then browse to and select the folder of the CH340 driver provided on the SD card.

    2 things every program needs to know to connect:

    • Speed or baud rate -- the printer connects at 115200. Enter that in the settings.
    • Serial port or COM-port -- Some detect it automatically, some not. Mine is shown above. I would enter COM4 in the terminal program. Different USB ports on your laptop use different COM-ports.


  • @telephasic Thanks for the feedback. Tried the first thing SD card inserted, power on, no good. Herein lies the main problem, the printer WILL NOT connect to my laptop. I have down loaded the drivers from the SD card, says they are loaded however device manager WILL NOT connect to the printer. I guess I could try an octoprint/rasberry set up, but i dont wont to spend another couple hundred of bucks to find out it wont connect either.



  • @CrankyEv
    You know, I think it might be as simple as trying it again, but with the factory SD card inserted when you power it on. That SD card probably contains a file called EEPROM.DAT, that has all your old settings. Because it sounds like your E-steps are not set or not found.

    If that doesn't solve it, read on. I did come across this:
    Teaching Tech 3D Printer Calibration
    https://teachingtechyt.github.io/calibration.html#esteps

    8f1147a2-188f-4a6d-b684-6661478c6714-image.png

    So it sounds applicable. Do you have a terminal set up? If not, to do the mentioned commands, you'll need to install some software on a computer and plug it in to the micro USB on the mainboard.

    Disclaimer: that connection can "backpower" the printer from the computer's USB through the cable. At best, it will try to light up the screen. At worst, it might damage something. Even if it's unlikely, I don't want to be responsible for frying your brand new board, so have a read of this thread, and maybe @SteveDee 's solution is the easiest.

    Lots of options for terminals. I am using OctoPrint on a raspberry pi, which has a terminal built in. Thomas Sanladerer just made a video showing how to set that up. He also mentions and links to the backpowering issue. But on a laptop you can use Pronterface like in Kris Kersey's video, or even just a bare terminal program like Putty also works for me and is enough for sending/receiving text commands if that's all you need -- as in this case. Let me know if you need help with any of that. Windows/mac USB drivers come on the factory SD card:
    40d34984-29ac-4c66-b5e9-e8201d46d22d-image.png

    Anyway, once you have a terminal running, begin by checking what E value you have set by sending the command:

    M92
    

    Here's what i get on my ender-6:

    Send: M92
    Recv: echo: M92 X80.00 Y80.00 Z400.00 E140.00
    

    What does yours say? If it's way off that, you could try setting

    M92 E140.00
    

    and

    M500
    

    to save the settings. Again, I think that will only be saved if you have an SD card inserted, but you can try and see if it works without. It normally makes or modifies that EEPROM.DAT and saves stuff there.



  • @telephasic got the new board. plugged in, firmware already on it. problem now is when i go to load the filament, extruder motor shaft just vibrates back and forth. changed wiring around motor doesnt work at all. if i plug the y motor wire to the extruder motor and press the move y axis the extruder motor spins correctly. any ideas?



  • @CrankyEv nice, happy to hear, hope it works out.

    have no experience myself- i would hope the board comes with some explanation included.

    i've seen youtubes of mainboard swaps like these...
    https://www.youtube.com/watch?v=cAI0H4e6Usg
    https://www.youtube.com/watch?v=2h70BOFB26o
    ...where all they did was swap boards and did nothing firmware/software related at all.
    just turned on and they work.
    those are for ender-5 plus, but maybe it's useful to see how they go about swapping all the wires, and i found their videos to be helpful in general (unsolicited plug). if you want thorough and methodical how-to's, see more of kersey fabrications.

    i would not try to flash a firmware before seeing if you can get one that's preloaded running first.

    hopefully it's that easy. otherwise maybe somebody who's tried it can chime in.



  • @telephasic Thanks. ordered one. question is do i just download the firmware file from creality and flash it to the board and it'll work or do i need config files and other files as well?





  • Thanks. i'll send them an email and ask if they deliver to australia. weird thing on their website is that they have an "in stock in australia" page, however all items are listed in U.S currency with send from overseas locations.



  • @CrankyEv
    Crappy deal man.
    Suggest asking around a bit before giving up.
    Maybe ask at https://www.creality3dofficial.com
    Or at vip mall. Don't get excited about the prices- they are wholesale. https://vip.creality.com/en/goods-detail/25



  • reading thru other posts im guessing its i need to program the g code into the firmware. tried connecting the printer via usb and fried the main board. i see creality dont sell new main boards for the ender 6 and cant get after market boards delivered here to australia, so i guess it will going back in the box and into the land fill. ill just go and buy a new printer from a reputable company.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.