Creality Slicer won't run on Windows 10



  • Hi.
    I'm new to 3D printing and the V2 is my first 3D printer.
    I installed Creality Slicer 4.2.1 and after the splash screen, I can't see the app. It's not running or it's crashing in the background.

    Is there a different version I need to use?
    I downloaded it from here: https://www.creality.com/download

    Maybe I'm using the wrong version for the Ender 3 V2?

    Also, how can I update the firmware? I think I'm running 1.0.0.2

    Thank you



  • When I first installed Cura 4.9.1 It crashed on startup. Turns out I need the dll - opengl32..dll. I downloaded it from here:

    https://www.azdll.net/files/opengl32-dll

    Once downloaded, unzip and place the opengl32.dll file in the main Cura program folder (not any of the sub-folders}. On my installation the path is C:\Program Files]Ultimaker Cura 4.9.1.

    After that Cura has worked fine for me.



  • Thanks!
    Downloading.

    How can I check if I'm running the latest firmware on my Ender 3 V2? and how can I upgrade it?



  • @Gil
    I had the same problem on multiple computers. It turned out to be a video driver problem. I was able to locate an Intel Open GL driver and it has been working. Had the same problem with Ideamaker on a different computer and this is also how I fixed it.



  • @Gil The latest version of Cura is 4.9.1 which you can download from here:-
    https://ultimaker.com/software/ultimaker-cura

    There is not a special 'machine specific' version.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.