Printer Stopping with "Unexpected stop" Error



  • I have an Ender 3 v2. Recently I have had troubles with print jobs automatically stopping once the extruder gets over a certain location on the build plate. When it stops, the message, “detect the file unexpectedly stopped last time” pops up. I’ve tried using a different SD card, I retightened the x-axis, since it seemed like it wasn’t working well. I have switched out with print job it is printing, and no matter what file I pick, it still stops this way (the location is sort of near the initial filament purge line before it gets to the main print).
    Is there something else that I should try or some part that I should replace?
    Thanks



  • if you have power fail recovery enabled, try disable . Also try disable filament runout, if you have those options availabe. I have seen similar with stopping during the first line or two of the purge filament lines due to either one of these, though usually there is a message to accompany them as they were falsly triggered. Re enable them if it makes no difference as they are useful when working.

    Depending on how long you have been using the printer succesfully, it may be a break/bad connection in the temp sensor or heater wires to the hot end or bed (wear and tear due to continous flexing), so it will kill() or just abort (no message) as a safety measure as it thinks (quite rightly) one of them has failed/is failing. This could explain why it happens in certain positions of the print head or bed as the connection makes or breaks during movement.

    The click usualy means a hard abort or freeze of the CPU/MCU or stepper drivers, so make sure your controller board fan is running and unobstructed as it may be overheating of the board. Similarly the PSU fan.

    Check the cables / wires plastic coating in case wear has worn through and causing an intermittent short, the PSU would make a click if this happens, so would the buzzer and likely crash controller board too.

    Could also come from loose 24V power cable connections at the PSU or to the controller board, would be nice that one as just tighten them up and your ready to roll (insert usual disclaimer here about unplugging printer from mains before jabbing your implements in there)

    If it is totaly random and usually with a click, it could be your air con. or other electrical noise crashing the cpu. add earth wire to PSU casing, connect to printer chassis and stepper motors and make sure it is properly earthed (ground spike or good and checked to be good earth connection of your mains supply). The paint on these usually prevents the earth in the PSU from connecting to anything else so you normally have to do this anyway, both for general safety and prevent random radio/electromagnetic interference from crashing your prints.

    The PSU in these is good so additional mains spike protection is not normally required.

    Make sure your belts are not too tight. and bed and head move freely. Stalled stepper=short so may cause stepper driver hard shut down and cpu hard abort. However that might also indicate loose power cables if belts are only a bit too tight or head or bed not moving quite as freely as might

    Check under the controller board if you suspect loose power cables but cant find any. Some have experienced the power connector pins coming free of the solder pads requiring them to be soldered back down



  • Thanks! I just tried that, and it failed to print in the same location (there's a little click when it stops). I tried a couple more things. I re-leveled the build plate just in case, and that seems fine now.
    I also tried out auto-homing. The first time I try and have it "auto-home", it will do that procedure just fine. If I try a print, fail it, and try to "auto-home", it will not move. I also tried starting the print with the extruder head sitting sort of in the middle of the build plate (to see if it would home), and the print fails without moving anywhere. There is no error message on that when it does that.
    Does this extra info help?
    Thanks



  • Dear @jobombeck

    Hi, this alarm prompt may be caused by wrong model slicing parameters in the memory card, or a memory card failure. We can send you a few test models, put our test models into the SD card for printing and check if the same alarm prompt appears during the printing process.

    https://drive.google.com/file/d/1Xjt9ko8Ey8Dsf9CHk2tQlClmOmeS6A_Y/view?usp=sharing


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.