RE: CR-10 Smart Firmware Update

  • I wish Creality had created a case for the lcd that had an opening on the right hand side for the sdcard slot.
    It would have made flashing the lcd a bit easier. I guess it's Dremel time.

  • @Yolanda I think Christophe95 is talking about when you run an auto level by itself without a print. The nozzle used to stay at a constant 120c the entire time.
    In the 1.10 firmware it fluctuates from about 120c to 110c.

  • Successfully flashed the 1.0.10 version into display and board. But I have some questions.

    1. Why during the auto leveling the temperature drop at 120 C and goes down at 110 C during process?

    2. The autoleveling has to be done with cold bed or hot bed ? I always do it with hot bed on my Ender 3 V2, so I don't understand why is not the same in case of CR10 smart.

    3. How can used the Aux leveling, there are 5 points but no possibilities to adjust mecanicaly?

    4. How can adjut PID, there is no autotune?

    5. I like to have a sound for start and finish print with M300 function in start and end gcode, M300 seem to be not activated in the firmware?

    I adjust X axes, tighten all screw, but continue to have bad bed levelling.

    Thank for your help.

  • @Ferrar1n Hi, when the machine is anto leveling, the temperature of the nozzle will drop naturally. when the auto leveling is finished, the printer will automatically heat up to the nozzle temperature required for printing, and this is the normal operation of the machine.

  • @Interceptor777 I'm with you man. If Creality would just release the firmware a lot of these issues would be fixed by the community. My Ender 3-Max never quite worked right until third party firmware came along.

  • @Ferrar1n Yeah, i'm scratching my head on that one too. Long ago I commented out the line that drops the temp...

    ;M109 S{first_layer_temperature[0]-50} ; set temporary nozzle temp to prevent oozing during homing

    I can't figure out how to stop it from going to the center and touching the build plate before every print. Since it's already up to temp I have to watch it because it'll leave a little blob of filament on the build plate. I'd hate for that to affect the print. If it's not in the gcode it must be in the firmware. @Creality, please give us control over this "feature".

  • @Ferrar1n That is a shame to hear. This is exactly the kind of problem which can be fixed extremely easily if we had the source code of the firmware which Creality is legally required to make available.

  • Just flashed the 1.0.10 version successfully
    But one problem so far. The Creality cloud app does no longer pair to the printer. Apart from that prints looking clean

  • Successfully flashed the 1.0.10 version into display and board.
    Apparently the extruder problem got fix,, but the temperature still drops when the print starts or when auto drops then get back to normal after a few seconds after print start... while when doing the auto level the temperature get really messy during the entiry process...

  • This post is deleted!

  • This post is deleted!

  • @sparks02 I had the exact same issue today - flashed the latest firmware (motherboard & display) and now it's like the extruder is just permanently turned off during all prints (now it's a $500 paperweight that makes noise). I'm a bit new to this, but does anyone have an idea how often Creality comes out with new firmware versions?

  • @goombah88
    Flashed it (1.0.9) successfully - into the display and the printer. Currently printing a benchy. No issues so far (still running). Did an auto-leveling after the flash, no PID (re-)tuning yet. No heater running-off into an error. Last PID tuning i did with beta 1.

  • bonj nouveau sur le forum je cherche re flache firmware ender 3 merci davence ou me rensiegner merci

  • @sparks02 You are correct. I posted about this in another thread. Nothing would extrude. I went back to 1.0.7 too. It's old but reliable.

  • @goombah88 This version is broken as well. Have weird nozzle temp fluctuations and nozzle temp errors. Tried 2 different prints and it would not extrude any plastic. The nozzle was just moving over the bed. Had to go back to 1.07.

  • @Korlbrien On a whim I just checked and they've posted a new firmware.

    CR-10 SmartMarlin2.0.6SWV1.0.9HWCRC2405V1.20904.7z

    I'm 20 mins in on a 7 hour print or else I'd check it out and report back. Care to take the plunge?

  • @Korlbrien Same here. No trick makes it work. It's a dud.

  • @Plucker This firmware is not working at all. Will not Flash to the motherboard at all. I held the the button for 5 min. Nothing.

    I have renamed it with something short and did it with out renaming it. Still the same issue.

  • @Plucker As you already stated, the latest CR-10 SmartCR-FDM-v2.5.S1_100_20210821 on doesn't work. Screen flashes fine but the board refuses to flash. That being said, I flashed the one you link to and it's borked too. Everything flashes fine and you think all is well until you try to print something with any height to it. As with an earlier beta firmware this version simply stops printing after about 15 mm. It just plain stops extruding. No clog, nada. Just. Stops. Extruding. So to get the print done I had to reflash 1.0.7. It's old but reliable. I REALLY wish they would do more testing before they release. Hell, they should bribe some of us who are active in the forums and report bugs to be alpha/beta testers for em. I know I'd be game if it meant helping to get a great release out to everybody. Ya listenin' Creality???

Log in to reply