RE: CR-10 Smart Firmware Update

  • @Plucker This firmware is not working at all. Will not Flash to the motherboard at all. I held the the button for 5 min. Nothing.

    I have renamed it with something short and did it with out renaming it. Still the same issue.

  • @Plucker As you already stated, the latest CR-10 SmartCR-FDM-v2.5.S1_100_20210821 on doesn't work. Screen flashes fine but the board refuses to flash. That being said, I flashed the one you link to and it's borked too. Everything flashes fine and you think all is well until you try to print something with any height to it. As with an earlier beta firmware this version simply stops printing after about 15 mm. It just plain stops extruding. No clog, nada. Just. Stops. Extruding. So to get the print done I had to reflash 1.0.7. It's old but reliable. I REALLY wish they would do more testing before they release. Hell, they should bribe some of us who are active in the forums and report bugs to be alpha/beta testers for em. I know I'd be game if it meant helping to get a great release out to everybody. Ya listenin' Creality???

  • @Plucker
    The links you provided seem to be truncated and do not work for some reason.

  • There is a version of the 1.0.8 beta2 about that works but the one on the Creality downloads site definitely does not install and helpfully they removed the previous beta from the download page:

    Our latest firmware has been released, you can re-flash our latest firmware.
    And this new CR-10smart firmware works with this software.
    Be sure to keep pressing the round switch on the side of the machine during the process of flashing the firmware, otherwise the firmware will easily be lost.
    First back up the SD card and format it as FAT32, then copy the bin file to the SD card.
    Note that there can only be one bin file in the SD card, (the bin file is the firmware), please rename the file to a simple character, such as: "aaa" (and you must change the file name every time you update the firmware).
    Then insert the memory card into the machine and turn it on. After refreshing the firmware, unplug the SD card and reformat it. Do not save the firmware file in the card during normal use.
    When the display firmware is refreshed, set the format to FAT32 and 4096. At the same time, keep pressing the circular switch on the side of the machine when refreshing the firmware.

  • Having the same issue with 1.0.8 Beta 2 from here since 31th August:
    the display will flash but the marlin board not with this version.

    1.0.8 Beta 1 which I got the week before flashs successfully into the marlin board. Got it from here:

  • @lammy I'm running into this as well. I've been trying different combinations of the 1.0.7 firmware and the 2.0.6 BETA on both the box and the screen. So far no luck.

    WAIT - I just got it to work! It just forgets the language. Tap on the gear icon, then the middle icon and select English. Once I did that all the button text reappeared.

  • @Raymond812 I'm having a massive issue trying to get back to a working firmware. Tried the steps multiple times and the issue versions seem correct, however my screen doesn't actually display certain aspects of the buttons. So for example, it doesn't show the text within the buttons you press, they're all blank

  • Hi Raymond

    How did you flash the firmware? My printer is currently not booting anymore. When I press the power button, it stops almost instantly. It only works if I hold the button down for a longer period. The screen firmware was flashed ok


  • Thank you! I was getting pretty frustrated trying to get it to update. I had to hold the power button down for the whole update process, main board and display. Hope this helps anyone else having issues updating.

    It is weird that their help video shows a different version too. Oh well.

  • After spending few hours of trying out different SD and microSD cards finally I got it all straighten it now.

    The tricky part is need to find a small size of memory card and have to be format into FAT32.
    The video instruction is a bit off. It's not the *.hex it's the *.bin.
    Also the instructions are not that clear. For flashing the printer you need to press and hold the power on button like 5 sec to let it do the firmware flashing. If you just power it on it won't work.

    Hope this can help someone else might having the same issue.

    Happy Printing 😃

  • I got it all straighten it now.

    Flashed with the HW 1.07 and Screen to T19 with the Shutdown function.

Log in to reply