RE: CR-10 Smart Firmware Update

  • I'm trying to do the firmware update with my CR-10 Smart.

    Current Setup with HW 1.06

    I downloaded the firmware files for the mainboard and the screen.

    I followed the instruction on the PDF file and formatted the SD card to FAT 32 with the only the firmware.bin file in the card.

    Printer is off and inserted the SD card and turn on the power switch at the back and press the on/off button. The printer boot up but it's not doing the firmware update.

    I wait for about 10 to 15 seconds and the printer will boot into the normal screen.
    Check the device information. It's still on HW 1.06.

    I try it few times it's still the same issue. Not updating.

    I also watch the tutorial video is firmware_name.hex but the firmware file is firmware_name.bin
    Not too sure do I need to rename from .bin to .hex ?

    Anyone did able to flash the firmware to HW 1.07 and also flash the screen?

    Any suggestion ? Thanks in advance.


  • @goombah88 hi, where can i get firmware 1.0.6 or 1.0.7?

  • I wish Creality had created a case for the lcd that had an opening on the right hand side for the sdcard slot.
    It would have made flashing the lcd a bit easier. I guess it's Dremel time.

  • @Yolanda I think Christophe95 is talking about when you run an auto level by itself without a print. The nozzle used to stay at a constant 120c the entire time.
    In the 1.10 firmware it fluctuates from about 120c to 110c.

  • Successfully flashed the 1.0.10 version into display and board. But I have some questions.

    1. Why during the auto leveling the temperature drop at 120 C and goes down at 110 C during process?

    2. The autoleveling has to be done with cold bed or hot bed ? I always do it with hot bed on my Ender 3 V2, so I don't understand why is not the same in case of CR10 smart.

    3. How can used the Aux leveling, there are 5 points but no possibilities to adjust mecanicaly?

    4. How can adjut PID, there is no autotune?

    5. I like to have a sound for start and finish print with M300 function in start and end gcode, M300 seem to be not activated in the firmware?

    I adjust X axes, tighten all screw, but continue to have bad bed levelling.

    Thank for your help.

  • @Ferrar1n Hi, when the machine is anto leveling, the temperature of the nozzle will drop naturally. when the auto leveling is finished, the printer will automatically heat up to the nozzle temperature required for printing, and this is the normal operation of the machine.

  • @Interceptor777 I'm with you man. If Creality would just release the firmware a lot of these issues would be fixed by the community. My Ender 3-Max never quite worked right until third party firmware came along.

  • @Ferrar1n Yeah, i'm scratching my head on that one too. Long ago I commented out the line that drops the temp...

    ;M109 S{first_layer_temperature[0]-50} ; set temporary nozzle temp to prevent oozing during homing

    I can't figure out how to stop it from going to the center and touching the build plate before every print. Since it's already up to temp I have to watch it because it'll leave a little blob of filament on the build plate. I'd hate for that to affect the print. If it's not in the gcode it must be in the firmware. @Creality, please give us control over this "feature".

  • @Ferrar1n That is a shame to hear. This is exactly the kind of problem which can be fixed extremely easily if we had the source code of the firmware which Creality is legally required to make available.

  • Just flashed the 1.0.10 version successfully
    But one problem so far. The Creality cloud app does no longer pair to the printer. Apart from that prints looking clean

  • Successfully flashed the 1.0.10 version into display and board.
    Apparently the extruder problem got fix,, but the temperature still drops when the print starts or when auto drops then get back to normal after a few seconds after print start... while when doing the auto level the temperature get really messy during the entiry process...

  • This post is deleted!

  • This post is deleted!

  • @sparks02 I had the exact same issue today - flashed the latest firmware (motherboard & display) and now it's like the extruder is just permanently turned off during all prints (now it's a $500 paperweight that makes noise). I'm a bit new to this, but does anyone have an idea how often Creality comes out with new firmware versions?

  • @goombah88
    Flashed it (1.0.9) successfully - into the display and the printer. Currently printing a benchy. No issues so far (still running). Did an auto-leveling after the flash, no PID (re-)tuning yet. No heater running-off into an error. Last PID tuning i did with beta 1.

  • bonj nouveau sur le forum je cherche re flache firmware ender 3 merci davence ou me rensiegner merci

  • @sparks02 You are correct. I posted about this in another thread. Nothing would extrude. I went back to 1.0.7 too. It's old but reliable.

  • @goombah88 This version is broken as well. Have weird nozzle temp fluctuations and nozzle temp errors. Tried 2 different prints and it would not extrude any plastic. The nozzle was just moving over the bed. Had to go back to 1.07.

  • @Korlbrien On a whim I just checked and they've posted a new firmware.

    CR-10 SmartMarlin2.0.6SWV1.0.9HWCRC2405V1.20904.7z

    I'm 20 mins in on a 7 hour print or else I'd check it out and report back. Care to take the plunge?

  • @Korlbrien Same here. No trick makes it work. It's a dud.

Log in to reply

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.