CR-10 Smart , auto leveling. how?



  • Hi,
    When I first turn on the new printer, I guess the first thing is to auto level. (firmware updated already to latest 1.07) as of date of this post.

    ok, Press Leveling -> Auto Level

    Screen shows a grid of boxes, all grey except for one which is cyan

    Press Start
    now were are cooking , some heating up to 120 celsius action . Strange temperatures is so low and bed is not heating?
    After nozzle reaches ~120 celsius homing, X / Y ok, nozzle ok, touches bed 2 or 3 times, good. Small pause and were are leveling! goes to positions in a grid and touches 3 times another box turns cyan and next, ok,

    All boxes filled and cyan colour. nozzle goes back to center of bed, I think it homes Z again for good luck?

    now, sitting 1 or 2 mm off the bed it does not do anything it is still 120 celsius, it must be thinking about it? 5 minutes, still thinking, 10 minutes err.. still thinking? 20 minutes.. Still 120 celsius and no movement, no bleep of buzzer or screen message of 'Complete Congratulations!' or "We failed 😞 please try again" nothing. Motionless and hot, like a rutting stag resting after a particularly strenuous rutt, but with even less motion.

    On the CR-10 Smart I returned it was exactly the same (was returned for other reasons) So both can't be faulty right.

    On the one I returned, pressing anything now would cause the head to home or whaever and scratch all the way accross the bed as it lowerd itself from the 2mm to sub zero while it was moving to home or center. So no way am I pressing anything, pressing up on Z in the last one was a hot nozzle on bed action disaster,

    So what do I do now? has it finished. does it save the 'leveling'? how do I know it is safe to do anything without the 'head into bed' party trick on this replacement?

    If I power off and wait a minute, power on then repeat, all the boxes are grey again, and one box cyan and homing and leveling again, all boxes cyan, and then the nozzle makes itself confortable in the middle of the bed at 120 celsius permanently, closely, eying the surface of the bed as if it is considering giving it a good ramming.

    Do I have a second faulty printer?

    What gives?

    Get bored and switch off printer to find information or instructions, can 't find any, Get bored and switch off computer. (pattern emerging here?)

    Ideas?



  • tried with sdcard, nope, no difference. just crashes head into bed if you perform any action after the auto level 'completes'.



  • @telephasic ouch, and there is no sample config for it yet in the Marlin repo. It will have eeprom on board though, at least the Ender do, you just enable it in Marlin and never need the crappy card again. Why don't they enable it seeing as it is built in and works perfectly if enabled? wow, I would have to be very careful about using the same card on my ender, in case it reads the card eeprom instead of it's own, all hell would break loose, I customized it a lot. 410 steps on the extruder , 380mm X so probe can reach all the bed, you name it

    New topic created, where is the eeprom stored on the Smart.

    Wonder if thats why it just sits there still pre heating after leveling, cant store mesh data?



  • @BaDboD said in CR-10 Smart , auto leveling. how?:

    @telephasic err, eeprom is saved on the SD-card? What is this? Is 'hip hop' back in fashion? I don't have an sd card inserted, it hasnt asked for one.

    Haha I know it's pretty terrible, but an undocumented "feature" of ender-6, thought maybe cr10s too. It never asks for SD card.. if there is one inserted, the mesh is saved there. If not, I guess it's just not saved. Their workaround to avoid mentioning this and requiring an SD card by just recommending measuring before every print.



  • @telephasic err, eeprom is saved on the SD-card? What is this? Is 'hip hop' back in fashion? I don't have an sd card inserted, it hasnt asked for one. I do hope not, I really dont to re-live all that, card corrupted and needs formatting every time you remove the card from the printer, again. So your basically having to re level and AUX Level every time you want to use the printer.



  • @telephasic Hi, thank you for your reply,

    The first printer did the same thing. Just stays there at center heated to 120 centigrade. But if I pressed back and tried home, or even raise Z (dont like it left just 1 or 2 mmm away from the bed) it would either directly plunge in the bed (was definately pressing UP for Z) or seems to home and then half way back to the center lowered it self into the bed.

    I did then test, by turning off the machine and back on again then pressing up for Z and it correctly moved up. I thought it might have been reversed as I have seen on some printers. but no, it did just go the opposite direction after leveling. Why it nose dived during homing I don't know , I was not pressing anything

    I think the problem is, I dont know if it is having any errors, The replacement does exactly the same thing after leveling would appear complete. I would have thought it would cooldown, and I don't want to scratch up the bed and damage the nozzle by pressing anything. So how do I tell if it has saved the mesh and it was succesful or it is in error state and waiting to nose dive?

    Sadly the CR-10 Smart has no serial, there is no USB port and the wifi 'does not work that way' Am going to rip that out and put a raspberry pi in, it is just a Creality Cloud WIFI box plugged in with all the proper connectors inside the case, so an easy swap out and I will have serial and wifi I can actually use. Also it looks like I can change the internal USB connectors about and have a usb cable hanging out of the side for serial so I may also do that. Two for the price of one 🙂

    Also , how do you use the 'AUX Leveling'? I am guessing somethign about a peice of paper and it moving to the mesh probe points and babystepping for fine adjustment? but I have no instruction or guide of any sort to know how it works or how to use it.

    I am used to BL-Touch UBL 10x10 mesh and all the auto leveling and z adjustment using a CR-10 Stock 12864 display and Marlin on my Ender 3 V2 That tells me things and seems clear in intent when you press things etc. This Smart is just a bunch of buttons and the head does what it wants and I have idea whatsoever what it wants from me.

    Why does it not cooldown after the bed leveling? did it fail? it completes all the blue boxes. Can I safely move the head up away from the bed, I would like it to back off the bed 5 or 10 mm after homing or leveling to make me feel safe and know I can interrupt it if it nose dives. It would also be an indication it completed,

    Leveling complete is confirmed by '100/100 probe points. completed' on the display on my Ender. Pre-heat is manual too so I expect to have to hit cooldown afterwards, but if it auto pre-heats, should it not auto cooldown?

    Anyway whatever. All in the dark and darent do anything cos I do not have any idea if it failed or not.



  • @BaDboD I don't actually have this printer, so somebody else will chime in hopefully.

    From what I've seen on ender-6, there are generally never any error notifications- if something messes up, it just freezes and may need power cycled. Maybe hooking a serial terminal up to it will give an indication for you.

    Also after successful leveling (ender6+BL) there is no notification, just all the squares in the grid are filled.

    In the video after his successful leveling, it looks similar.

    Wondering if your malfunctions have somehow to do with EEPROM saved on SD card (if inserted).



  • HI @telephasic ,
    Thank you. I have seen this one (there are not many more) but he does have a loose bed and the leveling does not complete, it aborts at that corner. Mine seems to complete, all the boxes are changed to cyan colour, I will need to run it again, but I think it homes again after returning to middle too if that is an indication of anything?

    Bed is not loose, was very loose when I got it, which was good, the first one I received was wildy overtightened in the middle two rollers and had even bent the rails. but was flapping about like that one in video at the same time. LOL It is free rolling and has no axial motion of any sort, feels solid yet moves easily along the rollers. watchin from the sides during leveling it shows no movement at all as the nozzle probes

    In the video, it does not show if he receives any message about the error, and I don't hear any beep or other indication it failed, but all his boxes wont be cyan?

    I cant find any videos or information regarding how to know if it does not fail. what normally happens when it completes successfully?



  • @BaDboD maybe it helps
    https://youtu.be/ODUuQPit2Ek?t=4600
    He had a loose bed that messed up leveling.
    Tightened, then just hit 'back' after leveling.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.