Ender 3 V2 Auto-Home incredibly inconsistent - making prints almost impossible.



  • I bought an Ender 3 V2 a couple of weeks ago and over the last couple of days a really hard to solve problem has started to occur: the auto-home feature has become unusably inconsistent.

    Using the Auto-Home feature twice in a row will yield entirely different Z elevations for the nozzle (and so would require the entire bed elevation changing or a new Z-offset applying). This is bad enough as it is, but is particularly problematic when a print starts and the Auto-Home is carried out as an initial step....but sometimes the nozzle will end up several millimeters above the bed, and other times it will be pushing into the bed and no filament can get out.

    I temporary work-around may be to remove the auto-home part of the g-code, but I'd rather just fix the actual problem. Any ideas what might be wrong and how to fix it?

    The z-stopper switch thing isn't loose and the z-axis seems to move smoothly enough, but I'm willing to investigate anything at this stage.

    Thanks!



  • @crealityMatt when new, the springs under the bed will 'settle in' , Make sure you have tightend down the bed so there is plenty of compression on the springs, or you will start to see a lot of Z movement.

    after tightening down so there is still a little more to go before they are fully compressed you will need to adjust the Z switch height down to match then level it up again and check now to see if you still get a lot of variance. There will always be a tiny amount but nothing like you describe.

    Another would be to check your bed is still firm, in case the bed rollers have also settled in and need tiny scootch of adjustment.

    between those two when you press and lift the bed there should be very little to no vertical movement without some fairly considerable force.

    And of course if the free options dont work, then the switch, as @BobB said, is suspect. Make sure it isnt moving around, replacement is cheap so even if it is not the problem, you have a spare. I am used to either works or doesnt with the switch, and such a large variance in the mm is not something I would expect, but you never know. Unnacceptable variance yes. So much? Possible? Yes.



  • @BobB Thanks, I will try another z-axis switch if I don't get any other suggestions in the mean time! To work around the problem (rather than fix it) I removed the auto-home line from the g-code of any print I send, it's a bit of an extra hassle, but it does mean that the hot end is in the exact position I left it in after levelling the bed...no extra auto-home to mess it up.



  • @crealityMatt the z axis micro switch could be faulty. They're cheap to replace but even when working are not great on tolerance. I fitted a BL touch which has been excellent but I know others have had less positive experiences with them.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.