Creality/Cura Slicers Manitory Internet Access for slicing???



  • Can someone please enlighten me to why the Cura and Creality Slicers will not allow you to slice anything until you give
    the program(s) internet access to...

    Hubei - CHINA
    58.49.193.224 port 443- CHINANET Hubei province network

    Google Cloud in Brussels, Belgium
    35.190.207.247 port 443- Brussels, Brussels Capital, Belgium

    What is this?



  • Thanks guys for some insight on this, I run Win 7 and I have had no viruses for decades. I downloaded the slicers directly from the web sites and I still get this no slicing / internet access deal. I know it works from some and not others. I might just throw together another computer and see what happens. Thanks again hey.



  • @SteveDee Hi, I can confirm for you, that indeed is what the OP said.



  • 😨 I feel so violated! Wasn't a fan of this rebranding to begin with. Now I'm definitely removing Creality Slicer.
    Both Cura and Creality Slicer work and slice without internet for me. Maybe it asks access for the Marketplace and website links, and update checker. But I'd also be interested to hear what the connection is used for, if it doesn't slice without it for some people.
    Thanks guys for shedding light on it.



  • @BaDboD the OP said "...the Cura and Creality Slicers..."



  • @SteveDee It is only the Creality Slicer (which is cura but modified) and it does do this. It wont slice without internet access. ('connection lost to Creality servers' IIRC)



  • @gijoe1973 The first thing I did when I read your post yesterday was to disconnect from the internet and slice a model in Cura. I just wanted to confirm how you discovered this issue.

    I'm not having a problem, so wonder if you have some kind of virus, or maybe the slicer copy you have downloaded has been 'doctored'.

    Is your system running Windows OS? If so, maybe some other Windows user can do this simple check to see if it is a more general problem.

    I'm running a Linux distribution called Peppermint 10. As a test, you could download a Linux distro and simply make a Linux memory stick, so you can boot your computer into Linux, then install & run Cura on Linux (this should not affect or damage your Windows installation).

    There are lots of examples on the internet, like this: https://www.pendrivelinux.com/run-linux-mint-9-from-a-usb-flash-drive/

    I hope this helps.



  • Hi SteveDee,
    Try any 3rd party firewall program. It will pop up in the firewall alerts depending on the program/ setup, then you can research the IP addresses. I tried setting up a dedicated offline PC for my Ender 3 print area, found out you can't slice anything unless Cura / Creality has internet access when you go to slice each model. Unplug your Ethernet cable and give it a try. I just fine it odd how the places are in china and a google cloud in Brussels, Belgium. A packet sniffer would give you some more details too what is being sent i guess.



  • Can you explain how you know this, so maybe I can check my installation?


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.