Smart Kit webcam not working

  • Hi, I'm trying to use the smart kit webcam with my computer but it doesn't work (neither video nor microphone). I've tried windows, Linux and macOS and none of them seem to detect it. What's going on? Your product page says that the webcam is UVC and that it is compatible with all 3 operating systems. Do I need any additional driver? Thanks

  • @BaDboD thanks for the reply! When plugged, the cam appears in device manager in windows and under Linux it appears as UVC in dmesg. However, camera app on Windows gives some sort of error and cheese on Linux doesn't even detect it. I've tried OBS and apparently is detected only in windows, not Linux, nor MacOS. Even so, apps like zoom, Teams, Skype etc do not detect any video input so I can't use it. As far as I know UVC webcams are plug and play. What's happening with this one?

  • did you try OBS? when you plug it in, do you see it register as a device in syslog, or device manager? Certainly in windows a UVC device should show up as 'USB Video', if it needs a driver it will be under 'Unknown devices' but then it would not be UVC anyway.

    from syslog
    ~$ tail -f /var/log/syslog
    Aug 18 10:51:50 kernel: [ 53.593201] uvcvideo: Found UVC 1.00 device USB Video (534d:2109)
    Aug 18 10:51:50 kernel: [ 53.622510] usbcore: registered new interface driver uvcvideo
    Aug 18 10:51:50 kernel: [ 53.622513] USB Video Class driver (1.1.1)
    Aug 18 10:51:50 mtp-probe: checking bus 1, device 2: "/sys/devices/pci0000:00/0000:00:11.0/0000:02:03.0/usb1/1-1"

    not a Creality kit cam, just a generic UVC device.
    If it does not get detected at all then faulty is my first.

  • @Yolanda Hey, thank you for the reply but I'm trying to also use the webcam with my computer (as a conference webcam). Problem is that it's not detected. I've tried Linux, Windows and macOS and it's not compatible as your product page says: cd714809-114d-4a89-b394-e3f504122f4b-image.png

    Does it need any special driver?
    Thank you!

  • hi, @jonah1024 In this case, you have to update the firmware.

    1. Please download the Creality Box firmware from

    2. Unzip the file and paste the file 'root_uImage' to a USB flash drive or a fat32 format SD card.

    3. Insert the USB drive to one of the usb ports on the wifi box, using a pin to press the reset button when the box power off, keep pressing as you turn on the box, don't let go until you see the green light on.

    4. Wait and pay attention to the light status, when all lights go off and yellow light on again, it indicates that the box has been fixed successfully.