Display not working properly when rolling back firmware



  • I have numerous sections of the control system that don't actually show anything on the buttons. Another issue is the tick indicating soemthing is on is the inverse. So a tick lit up means to fan/lights are off instead of on



  • @lammy have You solved this problem?



  • @lammy
    hi,
    i suspect first a bad/wrong connection in your display box.. a continuity check end/end of your wires should be done (sometime it’s visible for the eyes if you check it).. if all look good less to open it, yes, you need to open it for to see or test the continuity.. if you can, naturally..
    note: if your display have only 4 wires (on the connector), it’s a I2C communication protocol which mean a bad contact here = no display at all).. have you some supplemental data/details to say?



  • hi, @lammy try to update the mainboard firmware and screen firmware again; If the problem cannot be solved, please send the email to cs@creality.com and attach the fault video. there are professional technicians helping you solve the problem.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.