📣📣CR-10 smart latest firmware has been unveiled

  • Dear friends,
    Creality has uploaded the latest firmware of CR-10 smart in the official website (https://www.creality.com/download). The leveling-free issues and the progress bar at 99% after printing issues and back to zero issues are fixed by the new firmware.

    If you need it, please check and download it. Thanks.


  • This post is deleted!

  • Tried it. Cant seem to figure out how to move the Extruder though. Seems like they took that away.

  • CR-10 Smart Running FW 1.0.10. How would I obtain all of current values necessary to calibrate my printer? Also, I don't see away to move the Extruder so I can calibrate that. Seems this firmware is missing a lot of basic capability. I can't connect to the machine to send commands to it (I can but its way more work than should necessary just to calibrate the printer). Creality your leaving us stranded here. This is basic stuff.

  • @bfilion05 I find that the Extruder Head has to 'home' to center first upon entry into the Bed Leveling menu. Once that it is done, I can then select Auto. Running 1.0.10 FW here.

  • @Scrambler You are correct. It is a bug in the latest firmware. Mine started staying at 0% a few weeks after I installed the latest 1.0.10 firmware. Very odd. One time I had to kill a print right after it started and ever since my progress bar/timer has been stuck at 0%.

  • @mattu008 said in 📣📣CR-10 smart latest firmware has been unveiled:

    autoleveling feature no longer works

    Hi everyone.
    I got my CR10-Smart yesterday and updated the firmware to latest version.
    I noticed that progress bar/gauge does not work during prints (it stays always at 0%).

    Anyone experiencing this issue and has a fix for this?

  • Did think it might of had one but with this design I was unsure which (if it had one) it was. But I found it. All good now, thank you for the your update 👍

  • @Corsair2020 There should be a tensioning screw on the extruder.

  • Just when I thought it was safe to start printing,low and behold the extruder problem starts again, but this time I found the culprit to be the tensioning arm of the 'E' extruder. It was so tight to the filament that it started to flatten it as it was going into the bowden tube leaving a lovely row of tooth marks in the filament. So disregard my last post condemning Creality's bowden tube....Now how I'm going to fix the tensioning on the feed....I really do not have a clue as yet.e drive.jpg

  • @Corsair2020 Glad you discovered the problem and it was an easy fix. I bought some capricorn tubing but I haven't installed it yet. Guess maybe I should accelerate those plans. 🐵

  • @Corsair2020 Okay, so not all went well. the dreaded E stoppage halfway through the print, BUT I found the culprit....The Bowden tube that came with the printer. the E drive had sawn through the filament, but why? Turns out that the tube was expanding slowly at the hotend causing the filament to bind until it could no longer break free from the friction caused by the binding. Answer? replaced with a more superior Bowden tube. Printer now running faultlessly....Happy days, until the next problem rears its head.

  • Went back to HW 1.07 T19, but this time I disconnected the touchscreen before flashing the firmware, turned off and reconnected the touchscreen and loaded the sd card with T19. when finished, switched back on and did an auto bed leveling. the temperature went to 120 and fluctuated 1 degree +and - where before it would go to 120 and the slowly drop to 110 Aux graphic no longer shows the 5 point level, but now shows the Z offset graphic. I've not as yet tried a print so can't say if that side of it is behaving or not. Hope this helps others, or maybe I was just doing it all wrong in the first place.
    Happy printing people.

  • @BrutonGaster Have you tried the firmware they just released yesterday? I ran a bed leveling test print and a hollow box and so far so good. I'll throw something real at it today but it looks we might have another good firmware on our hands 😁

  • @goombah88 Same here. Flashed the latest firmware just today. Extruder works just fine when I manually tell it to extrude some, but as soon as I try an actual print it seems to have stage fright and is just turned off the entire time. The X, Y & Z axis perform wonderfully, but the extruder is on vacation.

  • @goombah88

    Yes mee to just did the update yesterday.
    Firmware update was fine. When tried to print nothing came out.


  • SIGH CR-10 SmartMarlin2.0.6SWV1.0.9HWCRC2405V1.20904.7z doesn't work either. Tried 2 different test models and absolutely NOTHING gets extruded. There's no clog or anything. If I manually tell it to extrude via the Ready menu it works just fine. But during a print nothing comes out. C'mon Creality...get it together and actually TEST SOMETHING before you release it. Completely stock CR-10 Smart here...no excuses.

  • @admin CR-10 SmartCR-FDM-v2.5.S1_100_20210821.zip doesn't work. Screen flashed OK but the printer firmware won't do anything. Tried several times. I held the power button for over 2 minutes but all I ever saw on the screen was the initial 7 specks of light. Formatted both SD cards again but it didn't help.

  • This post is deleted!

  • Another bug report:

    The screen - especially on 1.0.7 with screen T19
    - I have to select everything twice. For instance, to print something I have to tap the file name twice and then the Play icon twice.
    - Also, would it be possible to rearrange the items on the screen on the next release so that you can see more of the filename? You only get to see the first few characters which can make it difficult to pick the right file. I know I'm not the only one who likes to name their files to include details so you know which is which.
    - Example:

Log in to reply