📣📣CR-10 smart latest firmware has been unveiled

  • Just when I thought it was safe to start printing,low and behold the extruder problem starts again, but this time I found the culprit to be the tensioning arm of the 'E' extruder. It was so tight to the filament that it started to flatten it as it was going into the bowden tube leaving a lovely row of tooth marks in the filament. So disregard my last post condemning Creality's bowden tube....Now how I'm going to fix the tensioning on the feed....I really do not have a clue as yet.e drive.jpg

  • @Corsair2020 Glad you discovered the problem and it was an easy fix. I bought some capricorn tubing but I haven't installed it yet. Guess maybe I should accelerate those plans. 🐵

  • @Corsair2020 Okay, so not all went well. the dreaded E stoppage halfway through the print, BUT I found the culprit....The Bowden tube that came with the printer. the E drive had sawn through the filament, but why? Turns out that the tube was expanding slowly at the hotend causing the filament to bind until it could no longer break free from the friction caused by the binding. Answer? replaced with a more superior Bowden tube. Printer now running faultlessly....Happy days, until the next problem rears its head.

  • Went back to HW 1.07 T19, but this time I disconnected the touchscreen before flashing the firmware, turned off and reconnected the touchscreen and loaded the sd card with T19. when finished, switched back on and did an auto bed leveling. the temperature went to 120 and fluctuated 1 degree +and - where before it would go to 120 and the slowly drop to 110 Aux graphic no longer shows the 5 point level, but now shows the Z offset graphic. I've not as yet tried a print so can't say if that side of it is behaving or not. Hope this helps others, or maybe I was just doing it all wrong in the first place.
    Happy printing people.

  • @BrutonGaster Have you tried the firmware they just released yesterday? I ran a bed leveling test print and a hollow box and so far so good. I'll throw something real at it today but it looks we might have another good firmware on our hands 😁

  • @goombah88 Same here. Flashed the latest firmware just today. Extruder works just fine when I manually tell it to extrude some, but as soon as I try an actual print it seems to have stage fright and is just turned off the entire time. The X, Y & Z axis perform wonderfully, but the extruder is on vacation.

  • @goombah88

    Yes mee to just did the update yesterday.
    Firmware update was fine. When tried to print nothing came out.


  • SIGH CR-10 SmartMarlin2.0.6SWV1.0.9HWCRC2405V1.20904.7z doesn't work either. Tried 2 different test models and absolutely NOTHING gets extruded. There's no clog or anything. If I manually tell it to extrude via the Ready menu it works just fine. But during a print nothing comes out. C'mon Creality...get it together and actually TEST SOMETHING before you release it. Completely stock CR-10 Smart here...no excuses.

  • @admin CR-10 SmartCR-FDM-v2.5.S1_100_20210821.zip doesn't work. Screen flashed OK but the printer firmware won't do anything. Tried several times. I held the power button for over 2 minutes but all I ever saw on the screen was the initial 7 specks of light. Formatted both SD cards again but it didn't help.

  • This post is deleted!

  • Another bug report:

    The screen - especially on 1.0.7 with screen T19
    - I have to select everything twice. For instance, to print something I have to tap the file name twice and then the Play icon twice.
    - Also, would it be possible to rearrange the items on the screen on the next release so that you can see more of the filename? You only get to see the first few characters which can make it difficult to pick the right file. I know I'm not the only one who likes to name their files to include details so you know which is which.
    - Example:

  • @Korlbrien I used the regular flashing procedure. You I could power cycle again after each firmware flashing so you know you got a good, clean, normal boot. That fixed an issue I had where I couldn't select the Settings icon at all.

    • firmware.bin on the SD
    • push and hold power button til it's done flashing and boots up.
    • put the DWIN folder on a micro SD and flash the screen with it.

    NOTE: After flashing new firmware, if you see icons with little or no text, go to the settings screen and reselect your language. That fixed the text for me.

  • @admin It appears I spoke too soon. BIG problem now. I've tried 3 times now to print a small drawer and each time it stops extruding after 10-15 mm. Total height of the drawer is 58 mm. The printer keeps going through the motions, but no filament comes out. There is no clog or anything...it just stops. Talk about a waste of filament. I'm going reflash 1.0.7 just so I can finally get this project done.

    Say...what's the compensation from Creality for being a firmware beta tester? I need to get on the payroll LOL

    P.S. And yes, I did try re-slicing the model.

  • @goombah88 How did you get the firmware to work? Mine is not taking.

    Does the Auto Bed level work yet?

  • @admin I just updated using this latest firmware and it resolved the issue with reading what's on the SD card. On a side note though, in the file list it also shows .Trash-000, so if you could please ask them to either hide all hidden files (. files) or at least ignore the Trash folder. Thanks for the quick turnaround on this!

  • Has anyone gotten 1.0.8 to work? It load successfully, but the interface seems very incomplete. You can barely even navigate it. And, I do not even see an option for auto leveling...

    After about two weeks of everything working well, I have leakage spill through the nozzle causing damage to the hot end. Since replacing it, I can not get the CR-10 smart to come even close to laying down a first layer. Arguably it is barely doing anything. Much guess/hope is that the nozzle is just too close to the bed. After reading all the issues about auto leveling not actually working, I was hoping this may solve the problem.

    I am at a bit of a loss still and really don't know what the issue is.

  • The firmware updates again, please check:


  • I'm having this same problem. 1.0.7 works fine, but no combination of 2.0.6BETA box and screen flashing works. The only time I got it to ready anything at all from the card after flashing 2.0.6BETA was when I renamed my file to holder.gcode. I suspected the firmware was compiled with an option that limited the filename length to 8 characters or something.

  • I installed the August 21 beta firmware on my CR-10 Smart. The autoleveling feature no longer works.

    That is, when I hit "start" on the autolevel, it homes in on the center of the plate and remains there. Additionally, the grid of 16 numbers has disappeared with this firmware.

    I have reverted to the Jun 28 firmware for now.

    Please let me know if you need additional details

  • Curious if anyone else is having issues get the ABL to work after flashing to this latest firmware? When I go into the Level menu, it will not let me click on the AUTO, only the AUX leveling appears and no screen change when I try to select the Auto bed leveling.

Log in to reply