Creality box, change z compensation to 0



  • I'm trying to set up the creality box but the z compensation always goes to 0 and my compensation is -2.72, therefore, the nozzle is too far from the bed. I don't know how to fix this, any suggestions?



  • @ivancamacho8 did you add your zoffset to the startup gcode inside of the creality cloud app? When you load your model to slice, select device at the bottom left, then Custom. Put in your parameters for your printer. Go to the Start G-Code section and put in your zcode offset.

    Taken from All3DP
    The key to adjusting Z offset using G-code is to home the printer first with G28 Z0.

    Next, G92 Z0.1 can be used to set a manual Z offset for printing. In this case, the printer has established the current (home) position to be Z = 0.1 mm. This will create a -0.1-mm offset, where any movement command after this will be lowered by 0.1 mm on the Z-axis.



  • I have the same problem now. Not sure why. It never used to do it. Did a reset also. Ive stopped using it. defeats the purpose if you still have to manually adjust your offset on your machine on the fly so it will work. Maybe there is a firmware update that will be released to fix. Havn't been able to get the firmware install to work via mem card so thats a option you could try if you havnt already. Your also susposed to be able to plug a webcam in...i bought their webcam to plug in...it stops working when i do lol...i dunno...if I can figure out how to stop it from doing the zeroing thing i will for sure reply again 🙂 its really annoying!!


Log in to reply