CR10 Smart Touchscreen not responding to touch.

  • My touchscreen is not responding to my touch. I tried it after I assembled the machine to do the autolevel. It didn't work. I updated the firmware in the machine and in the screen to the latest firmware It still did not respond to my touch. Any suggestions, I got this as a Christmas gift so I am only two days with it.

    I checked the cables to make sure they were tight both in the screen assembly and on the motherboard. I restarted the machine several times before and after each attempt to make sure it was not a startup glitch.

    Still unresponsive. Any suggestions. I seem to have to wait for Monday to speak with Tech Support unless I want to make an international call.

  • weird, mine was always responsive straight away, didn't do anything useful (like print), but it did instantly drive the nozzle hard into the bed the moment you pressed anything on it, no delay at all. replaced the entire printer 3 times, and all were the same so I think they are not supposed to take several minutes to be responsive. pressing autolevel was the only thing did work without ramming the nozzle into the bed immediately, and that worked within about 30 seconds of power on. So no should be pretty much immediately responsive.

  • Did you ever get the touchscreen sorted out? If not you might wanna try flashing the screen again. Are you using firmware 1.0.10 from Sept?

  • @Tumbleweed Patience. The front panel FW boots up fast but the machine FW takes longer. Allow the machine about 5 mins after the panel boots up and then see if the panel is responsive. That's what works for mine. Btw, I just got mine in Nov and had the initial FW on it (can't recall which) and then updated the fw to 1.0.10. Both FW levels behaved the same.

Log in to reply