Stuck in splash screen, won’t boot up



  • When I turn on my printer, I see the Creality name on the touch screen with a progress bar. But it never gets past this screen. The printer won’t boot up. I have not yet tried to reinstall the firmware. Hoping this will fix the issue.



  • @SpencerSpinn Hi
    I've had the same problem and I finally figured out what was wrong. Somehow the SD card got corrupted and the firmware on the main board and on the screen also got corrupted. I tried to update the firmware with CURA and it didn't work. So I used Creality's Slicer to upgrade the firmware on my CP-01 mainboard & it Worked. I also upgraded the screens firmware through the microSD card slot on the screen with the .hex firmware file. The screen updated no problem but I still had the boot screen and nothing else until l upgraded the firmware on the mainboard through Creality's Slicer. My CP-01 is up & running again. I hope this helps. 👍👍👍



  • @admin I tried, but didn't work. Here's what happened:

    I just got my printer, unboxed it, set everything up, and powered it on. It booted up fine, I did the auto bed-leveling like it said to in the manual. But when I inserted the sd card to try to print something, it couldn't read the files. So I turned it off, went to my computer and moved the g-code files to the root, put it in the printer, turned it on, and I'm stuck on the splash screen. I pulled the sd card out and tried again - stuck on splash screen. I followed the firmware upgrade info and put the .bin firmware file on the sd card, power on - stuck on spalsh screen. I don't know what to do. Any other help?



  • So far, I have been unsuccessful. My printer is still stuck in the boot up screen



  • I have the same issue. Did the above solve the problem by any chance?.



  • @MattySarv just got my printer today, same issue. Won't even get far enough to update the firmware. Did you figure out a fix for this?



  • @MattySarv
    Try Download the firmware from here: https://www.creality.com/download.
    and flash the firmware as the tutorial said:
    Mainboard Firmware Tutorial:
    https://www.youtube.com/watch?v=AKIfwPgN0qs&feature=youtu.be
    Screen Firmware Tutorial:
    https://www.youtube.com/watch?v=Jswzrh2_ekk


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.