CR-6 Max Octoprint Temperature Errors



  • Has the issue of the doubled temperature entries reported by the CR-6 firmware to Octoprint been resolved?
    here are firmware variants shipped with some Creality printers that produce broken temperature reports. In the community we have so far seen two variants that are broken in different ways:

    Doubled temperature entries
    Your firmware sends temperature reports like this:

    TT::27.9327.93 //0.000.00 BB::39.6739.67 //0.000.00 @@::00 BB@@::00
    Note that all of the parts of the report are doubled: TT, ::, //, even the values themselves. This breaks with the protocol.

    Printers currently known to possibly ship with affected firmware are

    Creality Ender 3 v2
    Creality CR-6 SE
    A firmware update is available to fix this issue.
    Creality Ender 3 Pro
    Creality Ender 5 Pro
    Creality Ender 6
    Creality Ender 7

    Is there a solution?



  • Hi I was talking about this issue with Steve over on the Gambas One forums as I was getting this very same issue on my Ender 3. I have not upgraded the Firmware from what was installed in it from the factory. Going to my about page on the printer shows I'm running the following:

    • Marlin
    • Ver 1.0.1
    • 2020-04-25
    • Ender-3
    • Extruders:1
    • Baudrate:115200

    I have been writing a program to control my printer using the Gambas programming language and was perplexed by the response I was getting when sending an M155 S2. I kept getting the identical duplicate response that you described. I then tried running miniterm to see if there was something wrong with my program. miniterm reported the same duplication being sent from the printer so I knew it wasn't my software, but instead it was the printer. So then I went ahead and tried to snoop the communications between Cura and the printer as Cura monitors the temperatures. It turns out instead of sending a M155, they simply send a M105 every couple of seconds. M105 does report back properly. So I have since modified my Gambas program to send M105 every few seconds.

    This is unfortunately not a good fix as it does add a little extra traffic on communication port, but it seems to be the most reliable method.

    I could try and update the firmware, but unless I have a guarantee that the new version is fixed, I'm not going to risk upgrading to the wrong firmware and possibly bricking the printer. For it is currently working quite nicely with only this one minor (for me) issue.



  • @Ground-Source I was discussing this problem a few weeks ago over on the Gambas One website; from this post onwards: https://forum.gambas.one/viewtopic.php?p=5344#p5344

    I think its probably a bug in certain versions of Marlin software, so it maybe an idea to visit their issues page: https://github.com/MarlinFirmware/Marlin/issues?q=is%3Aissue
    ...or search/ask your question here: https://reprap.org/forum/list.php?415
    ...as I doubt that Creality will respond.


Log in to reply