New Owner - Menu Missing Items, Can't Do Anything



  • I have multiple issues with my band new Ender 3 Pro. (And one is that it's clear that nobody at Creality is over 50 and has to read any of their direction sheets! Especially the one for the CR leveller.)

    A week or so ago I just got an Ender 3 Pro and the CR Auto Levelling kit. It was a few days before I could put things together - then I had to undo things to make changes - like cable routing. (I know I'm not the only one who has had trouble with the included documentation, so I won't get into that.) I set my Ender up and watched some YouTube tutorials on levelling the bed. I also installed Cura on my Linux system and ordered a longer USB cable so I could connect the Ender to my computer.

    I was going to use a test pattern for bed levelling as my first print. I loaded it into Cura, but saw that even with the Ender connected, and even though lsusb showed the presence of a serial port when the Ender was hooked up (and it was gone when the Ender wasn't hooked up), Cura doesn't see the Ender.

    Okay, so I was going to load the object to test print - but there no "Prepare" option in my menu:
    23FD065D-D631-4C4B-B936-EC279A733CB5_1_105_c.jpeg Even when I have an SDCard in, I don't see "Prepare."

    I thought, "I know the instructions for installing the auto-leveller include something about updates," so I went on and installed that. I tried to update my system. On the download page, I found two files:

    Ender-3 pro 4.2.2 mainboard firmware(32 bit)
    Ender-3 pro 4.2.2mainboard--High Temperature Full Hotend Kit firmware

    Both are zip files. I wasn't clear about the wording on the 2nd one, since that makes it look like it's an update or supplemental image to add on. (I did check my logic board and it is 4.2.2.) I formatted an SDCard with fat32 (found ext4 file systems don't work) and put the 1st file listed on the card with nothing else. I turned off my Ender, put the card in, and turned it on. I don't remember if I got an error message or if the info screen came up, but nothing happened. (I thought it was automatic from what I read.) Also, I checked and realized that the ROM file in question is older than the one listed in my system's menus:
    1EFD1831-C1F5-4AD0-B8BB-964F24553150_1_105_c.jpeg

    So I am having multiple problems with this system:

    1. No "Prepare" choice on the menu - and, from the videos I saw, it looks like there's another item or two missing. I'm not clear how I'm supposed to warm up the extruder or the bed without that.
    2. I take it I'm on the most recent version of Marlin right now - am I right? Do I need to do anything to get it to work with the CR levelling probe?
    3. I removed the connection to the Z-Axis switch, as given in the directions, since the levelling probe is supposed to take over for that. I used the option to home my print head and it moved up a bit, but not back down and was far from the print bed:
      F21719AE-1566-49F1-9B62-66539047922D_1_105_c.jpeg Ever time I try to do that, it just moves the print head up more.
    4. Cura doesn't seem to realize, at all, that the Ender is hooked up via USB. I've seen a few posts elsewhere about this, but I'm still not sure about how to solve that.
    5. Not a "Must solve now" issue, but when I level the print bed, I tend to have to redo it a few times because it seems that when I level some corners, others become un-levelled. I'm assuming this is just part of "tuning in" everything.

    I can remove the levelling probe and reconnect the Z-axis switch, if necessary, but even if I do that, I still can't print anything since I can't use the Prepare option.

    So what do I need to do to fix these issues?



  • Hi please check the cpu version, RET6 means 512K, RCT6 means 256K. I will make firmware for your printer which will return the prepare option, better use the z axis switch because it works good



  • This post is deleted!

Log in to reply