CR 10S Extruder Stepper Motor / Wiring Issue?



  • Howdy everyone. I'm hoping someone here has an idea of how I should proceed.

    I recently did some routine maintenance on my CR10S. Cleaned and replaced the glass bed, got the dustbuster out and cleaned any dust and small plastic bits, and as my current spool of filament was getting super low, put in some new filament. No problems with anything so far. The nozzle heated fine. I pushed the filament through until it only had the new filament coming out. No blockages there. (This is PLA, by the way.) Tightened a few loose screws, checked the tensioners to make sure nothing had come loose. No worries anywhere. This printer has been working like magic for about 6 weeks with no problems at all.
    Now for the fun part. During my first print with the new filament (Ziro Matte White PLA) my print stopped extruding and began printing nothing. I caught it maybe 10mm into this. I stopped the print and checked my nozzle for clogs, as can sometimes happen when dealing with a new filament you haven't used before. Nozzle was clear. No clogs. Checked the Bowden Tube. No blockages or damage there. Next I checked the extruder gears. A little over a month ago I upgraded to an all metal extruder with different gears and it's been one of the best things I've done to my printer. I went in the menu screen and advanced the filament by 10mm. Seemed to work fine. So, I powered off and powered back on again and started a new print. Seemed like the problem was solved. The raft went down smooth and the first few layers of the print itself were looking good. Then, it did it again. Extrusion stopped and I was printing nothing again. Mind you, the X, Y, and Z axes are all functioning perfectly. So I went to the menu and tried to advance the filament again. This time, the stepper motor was humming but the gear wouldn't turn. I disassembled it to where it was just the motor and the wire that plugs into it. This time, when I tried to get the gear to turn, it rocked back and forth repeatedly. I went a step further. I plugged the Z axis cable into the extruder stepper motor and it worked just fine. So we know the motor itself isn't bad. Then I thought it might be the cable itself, so I opened up the box and unplugged the E-motor cable and replaced it with a brand new one. Still, it was rocking back and forth. I don't have a multimeter, so I can't check the voltage. The board has never been exposed to electrical surges or any other situation that would cause it to short out. Everything else wired into the board works just like it should. So after troubleshooting, I'm thinking perhaps this one cable port on the board has gone bad. Is that even possible?

    tl;dr I think the port that my stepper motor cable plugs into on the motherboard is faulty. How do I check this or replace it if need be? Or will I simply have to replace the entire board? Any help you all have is greatly appreciated.


Log in to reply