Please help - Brand new V2 stopped booting up, stuck at Creality screen.



  • Hi all,

    My brand new V2 had been working really well, but after only a couple of weeks it one day decided it would no longer boot up for me. It's stuck at the initial Creality screen, no progress bar appears and it never reaches the menu. No error messages... nothing. I've looked online and some have solved this by checking/replacing their thermistor (owing to the retaining screw being too tight and causing a short) and others have claimed to fix it by doing a firmware update. I've checked the thermistor insulation around the area under the retaining screw, and it was all intact, no breaks. I'm happy to do a firmware update, but even if that fixes the issue it would leave the question remaining as to how the original firmware became an issue.

    Is this a common problem? How can I troubleshoot this further? I wish the screen would show an error message so that I had something to lead me to the answer.

    Thanks.



  • Thank you so much for the reply @Richardnash666. I tried a reflash today of the firmware and ran into a couple of issues which I'm sure is just due to me being new to Creality products. I went to creality.com and checked the firmware downloads for the V2, and was surprised to find they had firmware listed for board versions 4.2.3 and 4.2.7. I was expecting to see v4.2.2 (the one I have) and 4.2.7 (the latest board version available). I assume this is likely a typo?

    So not wanting to potentially flash incorrect firmware, I checked out CrealityOfficial and CrealityCloud, and was surprised to see they both had different collections of firmware, and different methods of storing the files (e.g. Google Drive???). Are these sites dodgy or unofficial?

    I also saw in various YouTube videos that you have to flash the screen firmware first, yet the firmware downloads I saw on CrealityCloud were for the mainboard only, nothing was listed for the screen.

    Can anyone please clarify the correct download location of the firmware for v4.2.2?

    For reference, this is the page that lists 4.2.3 firmware: https://www.creality.com/pages/download-ender-3-v2?spm=..page.products_display_1.1



  • @irwazr

    I had the same issue and flashing the same firmware again resolved it for me.

    I think the issue appeared for me whenever I restarted the printer with an SD card in the slot.

    Have not had an issue with the printer not starting properly since I started using Octoprint


Log in to reply