Creality Slicer will not load on Mac OS

  • I am having a real time trying to get the slicer to work for my Ender 3 S1. I downloaded the Creality Slice v4.8.2, build 141 from the Creality site and it will not load. I am running Mac OS Monterey, v12.3.1, the latest version.

    I have tried on a MacBook Pro and and Macbook Air with the same result.

    I got all the way through the download and moving the program to the Application folder. When I double-click and launch the slicer, the icon in the doc bounces for about 10 seconds, but the app never loads. No messages or errors. It just dies.

    I tried the Cura slicer for Mac and it loads fine, but it does not have the profile for this printer. I tried to pick the Ender 3 and Ender 3 Pro and it is giving very odd results when I print the gcode output.

    Any advice on how to either (a) configure Cura for the Ender 3 V1 properly or (b) getting the Creality Slicer working properly. Much appreciated.

  • UPDATE I was able to install on my daughters Mac running Catalina and the Creality Slicer works fine. I went into the configuration and went screen by screen in Creality on one computer and Cura in another. The Cura install was configured for the Ender 3 Pro. I updated the values from Creality into the Cura configuration, option by option, including the GCODE snippets that are in the machine settings. Then I did a slicing operation on both computers with the same exact model. The Cura configuration shows the output as an 18hour print, but Creality showed it as 6 hours. So obviously something is not right, so that experiment was a fail. Looks like the Creality is not supported on Mac OS Monterey. Thoughts?

Log in to reply