CR Touch Z-Axis Home triggered

  • I purchased a new CR Touch module for my Ender 3 V2 (4.2.2). It arrived two weeks ago, and I installed it last weekend. I successfully updated the firmware, but cannot get the device to autohome. When I select autohome, the Y and X axis homes just fine, then the Z axis raises a bit, then stalls. The CR Touch unit flashes red and it won't let me select autohome or move the Z axis until I reset the unit.

    I did some troubleshooting in pronterface and found with the M119 code that the Z-limit switch is triggered at all times. I removed the original z-limit switch per the instructions, so I investigated the CR Touch module. When I manually pull the pin down and enter the M119 code, it shows the Z-limit switch as “OPEN”. When I release the pin and it automatically retracts, the M119 code shows “Triggered”. This leads me to believe the CR Touch device is defective as it will not automatically deploy the pin to autohome.

    I also already did the following troubleshooting:

    1. Checked cables for proper routing/placement/pin configuration.
    2. Checked cables for signal errors or pins not connecting.
    3. Restored the printer to original firmware without CR Touch and Z-limit switch replaced, and all works normally.
    4. Tried multiple variations of firmware from Creality site and from Marlin. Same error across all BL Touch and CR Touch firmware types/versions. Also tried the Jyres firmware. Still no luck.
    5. Checked creality message boards for solutions. Found a few others with the exact same problem, but no solutions posted.

    I think the CR Touch unit is defective and I have reached out to for a replacement, but no response after 1 week. Not sure what else to do...

  • @admin Please help. I have a useless printer until I get this resolved.

Log in to reply