Ender 3 w/CR Touch stops printing, no error



  • @admin hoping you can help here, not sure if it's a faulty board or what...

    The SD card reader has been showing "Card Inserted" but then "No TF Card" in the menu. I would remove and reinsert until it finally shows up in the menu to begin printing.

    However, the print stops midway through... about 20 minutes or so into a 2hr job.

    No errors are shown on the screen and the screen doesn't respond.

    I tried unplugging to simulate power loss so it would recover, which it did but the print did not resume... the menu showed "No TF Card" so I'm wondering if that was the issue to begin with... that the reader is faulty and lost connection mid print.

    Is this a known issue, and should I return the printer, as I've had it less than 2 weeks?
    Or is there a simpler explanation and fix?

    Thank you.



  • I second that. Format the card even between prints.
    If that doesn't work try printing over usb I find that more reliable.
    If that doesn't work check fan is running underneath the printer. The controller board might be overheating and crashing



  • I had a similar situation. Bought a printer. Not having time to assemble it, I lost my native SD card from it. The printer did not accept any other cards.
    I had to format the card. I formatted the card in FAT32, the cluster size is standard. After that, it worked. Maybe it will help you if there are problems with the card reader.


Log in to reply