Ender 3 V2 Black Screen after BLTouch Update



  • Hello everyone, I have another problem here with my Ender V2, weird one.... BLTouch V3.1 from Creality
    I have updated the firmware to the BLTouch firmware, installed the BLTouch, everything successfully (almost).
    At first after the Firmware Update the display didn't turned on anymore, at all, even doesn't light up. The printer itself is turning on, fan's are spinning but the display doesn't react at all. I have tried different Firmware versions for both printer and screen without any succes....
    BUT...
    Then i plugged in the USB cable from the PC and it has started to turn on, indeed no LED's are lightning when I turn the printer on without USB cable, as soon I'm plugging in the USB cable as with magic the LED's are turning on and the Display aswell, it is printing well and do the job right...

    So what is the problem this time...?



  • @beejack Hi, thank you for your thoughts, at the same time I have also contacted the creality's customer support via eMail and got responce... Well, they think the mainboard is burned out and I have to replace it... 😕



  • @Hronus
    Hi, it does seem as if the board is faulty. If I'm correct then the board is supplied with 24V and needs to be regulated to give 5V for the electronics.
    With the USB cable connected and the power supply on, can you heatup the bed or hotend? If nothing happens check the 15amp fuse on the board. It may have blown or may not be seated correctly in the holder.
    If it has blown it's a good indication there's an issue on the board.



  • @beejack Hello, thank you very much for the fast respronce, very appritiate it.
    The youtube video was nice addition but unfortunately didn't solved my problem. Firstly I have installed the BLTouch directly to the mainboard BLTouch slot (with changing the pins slots to the right positions), now I have tried to put it in as in the video you sent, unfortunately with the same result (changed the pins back to match the video).

    Regarding the firmware for the mainboard and screen - they are from the stock creality website downloaded (the one which are installed now). But yes I have also tried to install some 3rd party firmware's aswell with the same result.

    Also in this video you can watch his full behavior: https://youtu.be/keab1efEuTs

    The BLTouch I purchased is the Creality's Version 3.1 BLTouch from: https://www.amazon.de/gp/product/B082VSB9VP/ref=ppx_yo_dt_b_asin_title_o03_s00?ie=UTF8&psc=1

    I hope this will be helpful to help me come further

    Also please don't pay attention (and sorry for that :D) to the mess in the room 🙂



  • Check your connections on the motherboard. Is the ribbon from the board to the display connected correctly?
    If you use the incorrect firmware it can produce this sympton.

    I'm asuming you mean the LEDs on the BLTouch are lighting up? This is seeing the 5V through the USB lead.

    The correct firmware is :
    V4.2.2-Ender-3 V2-32bit Mainboard-Marlin-2.0.1-V1.3.1-BLTouch.bin

    For this you need to connect the BL Touch as per this video:
    https://www.youtube.com/watch?v=lI9ISEPPX0w&list=PL5UfhdgCEfhPn9Zdz-yabItZjDmqB9uK6&index=14&ab_channel=Creality

    you shouldn't need to change the DWin firmware but if you have, use the original file included on the Microsd card provided or from the website.

    the file is located in the zip file on the web site :
    Ender-3 V2 SD Card File_V1.3.zip

    both are available here:
    https://www.creality.com/download


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.