How to switch to CURA 4.7



  • @Acd75 Crap. Don't have that option with the Ender 3 Pro...



  • @iMars I have generally been getting very nice prints from 4.7.1 - when I have had issues it has been with adhesion, loose bed, or runout detection, which aren't slicer problems. I had heard at least one other report of challenges with 4.7, but I have not experienced any.



  • Nobody issues with version 4.7? I got 4.7.1 and circular/vase prints look terrible. Like it is stuttering. I've been told it is in the 4.7 software and it is better to stick to 4.6.

    And anyone who cares/like to share the profile for Cura (4.6)? I'm using now Ender 3 Pro as printer, not sure if that's good, or can be better with its own CR-6 profile?



  • For Linux, just copy the creality_cr6se.def.json
    from the github repository to: ~/.local/share/cura/4.7/definitions

    After that in the list of creality printers, the CR6-SE will appear.



  • Hi guys,

    I want to ask if also someone has trouble adding Cura profiles for the CR6 SE after after adding the profile of the printer in Cura.

    As i'm able to add the printer following the above steps, but when i'm trying to add print profiles, it says that it's added but it doesn't show anything.

    Thank you



  • @spauliszyn I got nozzle sizes. I made a set of changes before they showed (e.g., changed filename, added the word 'Nozzle', etc.), but ultimately landed on the configuration @speckone published. The folder may be important here, as i didn't even get an error until I put the nozzle size files in the cura configuration directory as described in speckone's readme.



  • Hi @speckone, I added all the files as your instructions and I still don't have nozzle sizes. Can I add them manually?



  • @Acd75 Good idea. I wish Creality would support upgrading to the latest software instead of just 'pinning' this post to let us fumble our way through it. I bet every one of their employees upgrades their smartphones as soon as there is a new version available so they should understand importance of keeping current.



  • Yes @rjamison, I did and I'm now running 4.7. Its working fine. Thanks so much for your guidance! 🙂

    Sorry for the delay because I didn't get to it until now.



  • There is a typo in the file 'creality_base.def.json'.....if you edit it in notepad++......line 8..... look for "Absolute positionning\n\nG1 X0 Y{machine_depth}"

    I'm not sure if it is causing the issue or not, but it might be why I got errors and @rjamison did not, since he only copied the 'creality_cr6se.def.json' file.

    -Mike



  • I've updated the files from the Creality Slicer and posted them here:

    https://github.com/speckone/cura_cr6se

    This fixes the missing nozzle sizes from the extruder settings too.



  • @Stonedog03 I posted the steps I followed (did it again to be sure). Are they clear, and do they work for you?



  • @barney I posted the steps in the thread - are they clear?



  • I've ported the files from the Creality Slicer. I've got a working profile in 4.7.1 and even got the nozzle settings working after much trial and error. You can find the files here:

    https://github.com/speckone/cura_cr6se



  • @spauliszyn I've installed the creality software and if you check the help and update function you can download the Cura. Install that too. Exit both programs, copy the contents of the installation directory and subfolders and paste them over the creality installation.



  • @rjamison oh - and if you can unpack the creality slicer installer andyou won't actually need to execute it.



  • I just re-did it to confirm the steps. This is on windows, which may matter.

    1. install the creality software
    2. install cura 4.7.1
    3. copy the "creality_cr6se.def.json" file from the "creality3d/resources/definitions/definitions" folder to the "cura 4.7/resources/definitions" directory (yes - definitions/definitions is intentional because there are two files with different dates and i took the newer one which was in defs/defs)
    4. launched cura 4.7, went through the first time user experience screens until I got to the 'select printers screen. I then scrolled down until I found the creality section and selected the cr-6se.
    5. Uninstalled the creality slicer
    6. loaded an model and sliced it

    No crash, no errors, just cura 4.7.1 goodness.

    My guess is you used the file from the resources/definitions directory (rather than resources/definitions/definitions) and it is buggy - i forgot that there were two and I only ever tried the newest one. Apologies if that's what happened - an oversight on my part, but perhaps a critical one that wasted your time.



  • @spauliszyn I didn't copy the _base file, only the cr6se-specific. I did not have a crash, and am using cura 4.7 just fine with the cr-6 as the target printer. I do not have other printers configured, and this was a clean install of 4.7 when I did it.



  • Hi @rjamison. Same for me. This is what happened:

    In the 4.2 folder "C:\Program Files (x86)\Creality Slicer\Creality3D\resources\definitions\definitions" I took both the "creality_base.def.json" and the "creality_cr6se.def.json" files and copied them over. The 'cr6se' said that it inherited from the 'base' file so that is why i took both. If other creality printers depend on the 4.7 version of the 'base' file i don't care because I don't have any of the other printers. I don't know why the 4.2 version has duplicate definition folders-in-folders.

    But now that I started with the new def files, I cannot select and activate the cr6. It keeps crashing but the crash report window duplicates a bunch of times and closes almost right away so I cannot see what the crash report says.



  • @Stonedog03 hmmm... I will review the steps and be more specific. A version of this worked fine for me.


Log in to reply