How to switch to CURA 4.7



  • @Stonedog03 I posted the steps I followed (did it again to be sure). Are they clear, and do they work for you?



  • @barney I posted the steps in the thread - are they clear?



  • I've ported the files from the Creality Slicer. I've got a working profile in 4.7.1 and even got the nozzle settings working after much trial and error. You can find the files here:

    https://github.com/speckone/cura_cr6se



  • @spauliszyn I've installed the creality software and if you check the help and update function you can download the Cura. Install that too. Exit both programs, copy the contents of the installation directory and subfolders and paste them over the creality installation.



  • @rjamison oh - and if you can unpack the creality slicer installer andyou won't actually need to execute it.



  • I just re-did it to confirm the steps. This is on windows, which may matter.

    1. install the creality software
    2. install cura 4.7.1
    3. copy the "creality_cr6se.def.json" file from the "creality3d/resources/definitions/definitions" folder to the "cura 4.7/resources/definitions" directory (yes - definitions/definitions is intentional because there are two files with different dates and i took the newer one which was in defs/defs)
    4. launched cura 4.7, went through the first time user experience screens until I got to the 'select printers screen. I then scrolled down until I found the creality section and selected the cr-6se.
    5. Uninstalled the creality slicer
    6. loaded an model and sliced it

    No crash, no errors, just cura 4.7.1 goodness.

    My guess is you used the file from the resources/definitions directory (rather than resources/definitions/definitions) and it is buggy - i forgot that there were two and I only ever tried the newest one. Apologies if that's what happened - an oversight on my part, but perhaps a critical one that wasted your time.



  • @spauliszyn I didn't copy the _base file, only the cr6se-specific. I did not have a crash, and am using cura 4.7 just fine with the cr-6 as the target printer. I do not have other printers configured, and this was a clean install of 4.7 when I did it.



  • Hi @rjamison. Same for me. This is what happened:

    In the 4.2 folder "C:\Program Files (x86)\Creality Slicer\Creality3D\resources\definitions\definitions" I took both the "creality_base.def.json" and the "creality_cr6se.def.json" files and copied them over. The 'cr6se' said that it inherited from the 'base' file so that is why i took both. If other creality printers depend on the 4.7 version of the 'base' file i don't care because I don't have any of the other printers. I don't know why the 4.2 version has duplicate definition folders-in-folders.

    But now that I started with the new def files, I cannot select and activate the cr6. It keeps crashing but the crash report window duplicates a bunch of times and closes almost right away so I cannot see what the crash report says.



  • @Stonedog03 hmmm... I will review the steps and be more specific. A version of this worked fine for me.



  • @rjamison - I tried copying the CR-6 definition from the Creality provide Cura to 4.7.1 and it didn't like it. I got an error message about my configuration being corrupt. Had to dump all my configuration to clear that message.



  • Thanks @admin but since you know the printer better than anyone else, do you have a recommendation? Could you provide an updated printer definition file?



  • @rjamison sorry could you please advise where I might find the files you mentioned and it would be much appreciated if you could explain in simple terms how I do what you suggest , I have a very limited understanding of computer terminology, or how to use some of these forums, but i can tell you my e-mail brian.ferguson@talktalk.net,
    Thanking you in advance ,(just in case i cant find this again)
    Regards
    Brian



  • @rjamison how did that work for you? Nothing else that needs to be changed?



  • @spauliszyn have you tried copying the cr-6 definition files from the distributed software directory tree into the cura 4.7 directory tree? Definitions directory, iirc.



  • Dear @spauliszyn

    I will put your post to be pin post and hope someone successfully will feedback you.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.