CR-6 SE Extruder Calibration

  • I use the default prints on the SD card and it worked good. I measure my extruder feed and I got 97mm out of 100mm. I change filament and then I was getting bad prints. I measure my extruder length an I got 65mm. So I put on a dual wheel extruder, but it didn't fix it. So how do you change the extruder speed on the CR-6 SE? I see video's for Ender 3, CR10, but No CR-6 SE.

  • @ncbob I too would like the firmware

  • @spauliszyn I suspect that it’s stored on the lcd board. The filament runout is disabled in the marlin source code they published so they are doing something non standard there too.

  • @ncbob, If someone could confirm this, this would be an important work-around for users are complaining about their settings disappearing. Obviously, there is no excuse for Creality to keep the actual EEPROM disabled as a long term solution since it's technically not a requirement to have an SD card inserted.

    So how would the resume print feature work if there is no EEPROM storage? I never tried it or even tested it. Obviously you would be printing from the SD card so it's a convenient storage media. But how would the firmware store the current gcode line index when the power is out?

    These are the mysteries of the nebulus 3D industry... 😉

  • @spauliszyn no it’s not you, it’s probably another quirk with this printer and how creality modified the firmware. Remember I just downloaded their version and enabled the eeprom. I think I will need to do a compare and see if they mucked around with some things they shouldn’t have. As far as I know the sd card should NOT be storing eeprom data . That’s the whole point of eeprom, it’s re-writeable.

  • @ncbob, is it possible that the machine uses the SD card as EEPROM storage?

    I usually leave the SD card out because I am connected to OctoPrint. But I noticed a file on the SD card called "EEPRON.DAT", also mentioned by someone on another post. So when I tried to install the new 3.6 firmware from Creality (no offence ncbob), I thought I would leave the SD card in (after installing and deleting the bin file). Now I can M500 like a boss!!! My Z-offset, extruder steps and ABL mesh are all saved between machine restarts.

    • To test, I took the card out and restarted. Everything was default and no ABL mesh was stored.
    • Put it back in and restarted. Everything came back.

    What the blinky-doodle! Is it me? Did I miss or ignore an important instruction step to:

    "SD card inserted, please leave, or gone all hope is"

  • @ncbob it definitely took it. It did noticeably pause before the progress bar continued and the firmware version is now I will try one more time after the current print.

  • @spauliszyn After you copied the bin file to the sd card and put it in the printer, it should've taken like 10 seconds before it started.

    Also you may want to try changing the name of the firmware.bin file it may not recognize it as a new one. I've been adding the date like this: firmware.2020.

    If we need to I'd be willing to do a screen share and see if we can figure out what's going on.

  • @ncbob, yup, I go to the machine info at CONTROL/INFO on LCD screen and it says there. M502 is accepted in terminal but not M500 or M501. I restarted the machine several times

  • @spauliszyn Are you sure it says

    You may want to do a M502, M500 then M501.

    Then you'll need to do the bed leveling and save it with an M500

  • @ncbob, I installed the file you provided and the printer reports 3.6 on the LCD.

    But when I try M500 or M501, the terminal says that there is no EEPROM:

    echo:No EEPROM.

    and after an M500, restart, M501 and M420...

    M420 V1
    echo:Invalid mesh.
    echo:Bed Leveling OFF
    echo:Fade Height OFF

    Am I missing something?

  • @ncbob sorry, my bad, now I saw that you posted the firmware.. I'm using my phone and I didn't saw it 🙂
    Thanks for the upload !

  • @ncbob Hi ncbob, could I ask you if you can provide the firmware that you compiled which is also calibrated ? It would be really helpful... As I had also a few issues when I did few prints with different filaments as when I was slicing with different temperature settings or speed, on the printer wasn't changing and I had always to change them from the printer itself. Also I didn't know that the settings were getting discarded after you were turning the printer off.
    I would try to do the firmware but I'm not skilled on that aspect...

  • @spauliszyn Here's the link to the latest version of firmware which has EEPROM enabled:

  • @spauliszyn You are absolutely correct, and I feel the same way about this whole project as you do. I've been working with 3d printers for over 7 years, and this printer by far is the biggest pile of doo doo that I've ever worked on. Yes I understand it's a kickstarter, but the number of issues and the basic functionality that was not configured is terrible. The EEPROM should've been turned on by default. It should require us to modify and compile a new firmware package to enable it. And I know that they knew about it based on the starting gcode they said you needed to put in your slicer. Having to set those things before every print is not something you should have to do.

    The firmware is working just fine, I haven't had any problems with it and I actually have my slicer dialed in almost perfectly now. I just used the Ender 3 profile in cura, modified the bed size, and changed the retraction from 3.5 to 5.5. Oh and I'm using the print settings from CHEP and they are the bomb.

    THe other thing that I'm really disappointed about is that they didn't enable or wire up the SPI interface to the TMC drivers which would let you monitor them and also adjust voltages and such and have sensorless homing.

    I'm actually NEVER going to buy a Creality printer again, and I currently have 7 of them out of my 19 printers. And I won't recommend them to anyone either for the exact reason you stated, how frustrating it is. It's a real shame because before the CR-6 the other printers have been great (except for the early CR-10 which had similar issues and lack of support)

    If creality isn't careful they are going to lose a TON of customers.

    I'll post the firmware after I get off work.

  • Awesome @ncbob!! I was hoping it was just a command sequence to enable the EEPROM but I guess I didn't follow other posts about it very closely, it was getting beyond me :P.

    Was there any other changes you made to the firmware? You said you were going to test it first, is it working out OK? Umm... is this going to void my warranty? [real questions in bold]


    If Creality has told us many times that you ABL once and should not need to do it again, they forgot the most important information that we should not power the unit off. On the other hand, because of risk of fire, we should not leave our printers unattended while the power is on.

    I don't know what your frustration is at the same level as mine because you seem to be more proactive and you are more used to the state of the 3D printing industry. But I am very upset and discouraged that I cannot achieve all the promises that were stated on the kickstarter page and the promises that this printer should be at a level of use equal to or better than their previous printers.

    Sorry about crying on your shoulder @ncbob. Maybe we need a 'Community Therapy' category on this forum.

  • @spauliszyn I can post a bin file again that you can use to flash your printer. You just copy the file to the root directory of your SD card then power the printer off and on again and it will update it. I’ll post it as soon as I have a chance.

  • Ok @ncbob, how do 'I' enable the EEPROM? I'm glad you have that capability but compiling new firmware is not an option for me in the near future. Please throw me a bone here because this sounds like the best news I've heard in a while. 😉

  • One thing to remember is that by default the EEPROM is not enabled, so anytime you power off or reset the printer any configuration changes you made (ABL, Steps for extruder, PID tuning) are lost.

    I went ahead and compiled the latest version from creality, and enabled the EEPROM, so now I can save my settings and don't have to worry about setting it every time.

    I've been having VERY consistent first layers, I also print the first layer at .4 (with a .4 nozzle) which is what I do on pretty much all my printers.

    I've been slowly bumping up the retraction because I was getting lots of stringing as well. I need to just stop being lazy and run the calibration scripts here: and then update everything and save it to eeprom.

    Those calibration steps are awesome, and it's made tuning my printers 1000x easier and all my printers are printing very high quality these days.

  • Hey @DreamWeav ,

    I too have this issue. Can someone at Creality @admin please explain or help fix this?

    I finally took some measurements. Here is the snapshot of one of them:
    2020-10-14 20.09.54 (Small).jpg 2020-10-14 20.11.43 (Small).jpg

    I basically got the calipers around 100mm and then held the left jaw hard against the filament.
    Then I selected 100mm extrusion on the CR6 LCD and allowed the filament to pull the jaws together against the runout sensor, giving the final measurement. It's a bit crude and I know I am not truely getting accuracy to the 0.01mm. But considering that the reference mark I made on the filament near my thump did not change, the calipers are reasonably easy to close and the filament is reasonably straight, I would say that I have a ± .5mm error. So the actual extrusion amount is 99.05 - 5.02 = 94.0 ± 0.5mm. Another measurement, same filament, gave me 95.6±0.5mm.

    I am getting decent prints, with a bit of stringing. I changed to the recommended 6mm retraction @ 60mm/s as Creality had suggested and I think it's better.

    But my main issue is the ABL and the first layer quality. I literally have to babysit the first layer and tweak the z-axis offset each time--always after an ABL and sometimes even on the heels of completing a successful print. That is all on another thread though

Log in to reply